Closed Bug 1601404 Opened 11 months ago Closed 11 months ago

Zoom "Reset" menu should be renamed "Actual Size"

Categories

(Firefox :: Menus, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: yoasif, Assigned: tanner.e.davies, Mentored)

References

Details

(5 keywords)

Attachments

(1 file)

Like Chromium and Safari.

The View > Zoom > Reset menu item should be renamed "Actual Size" in order to be more consistent with those browsers.

I kept this bug broad, but this can be refiled to Cocoa instead if it makes more sense for macOS, but I don't see a real reason why it shouldn't also apply to Windows and Linux.

See Also: → 1588895
See Also: → 1601411

I'd want someone from UX to weigh in before doing anything here. Eric, are you the right person?

Flags: needinfo?(epang)

Spoke with Betsy since this is a string change. We're both good with the change to "Actual Size"

Flags: needinfo?(epang)
Priority: -- → P3

Note that when bug 1588895 lands, this would say "Actual Size" when what it does is reset to global zoom, so if your global zoom preference is 150%, it'd set it to that - not 100%. That seems to be what other browsers do too, but it does feel odd to call it "Actual Size"...

Mentor: gijskruitbosch+bugs

Anyway, to fix this, we'd need to:

  1. change the identifier of the string at https://searchfox.org/mozilla-central/source/browser/locales/en-US/browser/menubar.ftl#123-125 - probably menu-view-full-zoom-actual-size would be a good choice
  2. change the label and access key properties to have correct values
  3. use menu-view-full-zoom-actual-size at https://searchfox.org/mozilla-central/rev/ea63a0888d406fae720cf24f4727d87569a8cab5/browser/base/content/browser-menubar.inc#182 .
Keywords: good-first-bug

Could I take this bug, please?

Assignee: nobody → tanner.e.davies
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ab1ac74d4a4
Change View>Zoom>Reset in menu bar to "Actual Size" to be consistent with other browsers r=Gijs,fluent-reviewers

Thanks for the patch!

Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
QA Whiteboard: [good first verify]
Regressions: 1618907
You need to log in before you can comment on or make changes to this bug.