Closed Bug 1601602 Opened 1 year ago Closed 11 months ago

Perma UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values: when Gecko 73 merges to Beta on 2020-01-06

Categories

(Testing :: web-platform-tests, defect)

Version 3
defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox71 unaffected, firefox72 unaffected, firefox73+ verified)

VERIFIED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 + verified

People

(Reporter: noemi_erli, Assigned: CosminS)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=aecfd7f620754519683b9048d3832982688498c0&selectedJob=279770347

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=279764011&repo=try&lineNumber=7712

[task 2019-12-05T12:34:48.153Z] 12:34:48 INFO - TEST-START | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html
[task 2019-12-05T12:34:48.169Z] 12:34:48 INFO - Closing window 42
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO -
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | # AUDIT TASK RUNNER STARTED.
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | Executing "setup-buffer-and-worklet" - promise_test: Unhandled rejection with value: object "TypeError: context.audioWorklet is undefined"
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | Executing "verify-rendered-buffer"
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | Audit report
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | > [setup-buffer-and-worklet]
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | > [verify-rendered-buffer]
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | First half of Channel #0 contains only the constant 0.
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values:
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - Index Actual
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - [0] 0
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - [1] 0
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - [2] 0
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - [3] 0
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - ...and 124 more errors. - assert_true: expected true got false
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - _logFailed/<@https://web-platform.test:8443/webaudio/resources/audit.js:50:18
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1984:25
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - test@https://web-platform.test:8443/resources/testharness.js:548:30
[task 2019-12-05T12:34:48.474Z] 12:34:48 INFO - _logFailed@https://web-platform.test:8443/webaudio/resources/audit.js:49:9
[task 2019-12-05T12:34:48.475Z] 12:34:48 INFO - _finalize@https://web-platform.test:8443/webaudio/resources/audit.js:215:19
[task 2019-12-05T12:34:48.475Z] 12:34:48 INFO - _assert@https://web-platform.test:8443/webaudio/resources/audit.js:228:12
[task 2019-12-05T12:34:48.475Z] 12:34:48 INFO - beConstantValueOf@https://web-platform.test:8443/webaudio/resources/audit.js:662:19
[task 2019-12-05T12:34:48.475Z] 12:34:48 INFO - @https://web-platform.test:8443/webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html:68:20
[task 2019-12-05T12:34:48.475Z] 12:34:48 INFO - @https://web-platform.test:8443/webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html:61:31
[task 2019-12-05T12:34:48.476Z] 12:34:48 INFO -

Flags: needinfo?(james)
Summary: Perma - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values: → Perma - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values: when Gecko 73 merges to Beta on 06-01-20
Assignee: nobody → csabou
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba6f7b326c95
Add expectations deleted by wpt-sync for release or beta. r=jgraham
Flags: needinfo?(james)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Status: VERIFIED → REOPENED
Flags: needinfo?(james)
Regressed by: 1602822
Resolution: FIXED → ---
Target Milestone: mozilla73 → ---
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a937de435186
Add expectations deleted by wpt-sync for release or beta. r=jgraham

This should be fixed by re-landing the patch here. ^^

Flags: needinfo?(james)
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Status: VERIFIED → REOPENED
Flags: needinfo?(james)
Resolution: FIXED → ---
Target Milestone: mozilla73 → ---
Summary: Perma - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values: when Gecko 73 merges to Beta on 06-01-20 → Perma UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | X Second half of Channel #0: Expected 1 for all values but found 128 unexpected values: when Gecko 73 merges to Beta on 2020-01-06
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f619147af863
Add expectations deleted by wpt-sync for release or beta. r=jgraham
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/028b40d8140c
Add expectations deleted by wpt-sync for release or beta. r=jgraham

^^ is because of the latest wpt-sync that deleted the expectations: https://hg.mozilla.org/mozilla-central/rev/f03309629a99508a5b75ba55e77dcc1764567d07

Flags: needinfo?(james)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f0d0f918cbf
Add expectations deleted by wpt-sync for release or beta. r=jgraham

Should be fixed by ^^.

Flags: needinfo?(james)
Status: REOPENED → RESOLVED
Closed: 1 year ago11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.