Closed Bug 1601632 Opened 2 years ago Closed 5 months ago

ThreadSanitizer: data race [@ mozilla::ScriptPreloader::MaybeFinishOffThreadDecode] vs. [@ mozilla::ScriptPreloader::OffThreadDecodeCallback] on mToken

Categories

(Core :: XPConnect, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox73 --- wontfix
firefox86 --- fixed

People

(Reporter: decoder, Assigned: tcampbell)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 1 obsolete file)

The attached crash information was detected while running CI tests with ThreadSanitizer on mozilla-central revision 6989fcd6bab3.

Filing this because it is amongst the frequent races in Mochitests. This race is apparently on updating the mToken pointer. Should that be an atomic to ensure that the update is properly visible?

General information about TSan reports

Why fix races?

Data races are undefined behavior and can cause crashes as well as correctness issues. Compiler optimizations can cause racy code to have unpredictable and hard-to-reproduce behavior.

Rating

If you think this race can cause crashes or correctness issues, it would be great to rate the bug appropriately as P1/P2 and/or indicating this in the bug. This makes it a lot easier for us to assess the actual impact that these reports make and if they are helpful to you.

False Positives / Benign Races

Typically, races reported by TSan are not false positives [1], but it is possible that the race is benign. Even in this case it would be nice to come up with a fix if it is easily doable and does not regress performance. Every race that we cannot fix will have to remain on the suppression list and slows down the overall TSan performance. Also note that seemingly benign races can possibly be harmful (also depending on the compiler, optimizations and the architecture) [2][3].

[1] One major exception is the involvement of uninstrumented code from third-party libraries.
[2] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[3] How to miscompile programs with "benign" data races: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf

Suppressing unfixable races

If the bug cannot be fixed, then a runtime suppression needs to be added in mozglue/build/TsanOptions.cpp. The suppressions match on the full stack, so it should be picked such that it is unique to this particular race. The bug number of this bug should also be included so we have some documentation on why this suppression was added.

Component: General → JavaScript Engine

Hmm. Looks real; ScriptPreloader::WaitForCachedScript calls MaybeFinishOffThreadDecode() three times, sometimes with mMonitor held, sometimes not, which seems fishy.

The first line of MaybeFinishOffThreadDecode reads mToken which I think has to be done with the lock held, since it is set here with the mutex held.

Kris, can you take this?

Component: JavaScript Engine → XPConnect
Flags: needinfo?(kmaglione+bmo)
Priority: -- → P3
Assignee: nobody → a.beingessner
Status: NEW → ASSIGNED
Pushed by abeingessner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f14d44bacf2
Remove supression for seemingly fixed issue. r=decoder

roundabout triage: still an issue

Flags: needinfo?(a.beingessner)
Assignee: a.beingessner → nobody
Status: ASSIGNED → NEW
Attachment #9184489 - Attachment is obsolete: true
See Also: → 1677913

The mToken is used across threads without full locking so it must be marked
as atomic. At the same time, we can use exchange operations to read or
write outside of the mMonitor lock.

Depends on D99402

Assignee: nobody → tcampbell
Status: NEW → ASSIGNED

Add mWaitingForDecode to indicate that main-thread is blocked on the
Monitor and should be woken. This avoids generating some of the unused
Runnables. Also ensure mFinishDecodeRunnablePending is only accessed while
holding the lock.

Depends on D99403

Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2497e2dd2ae8
Make ScriptPreloader::mToken updates Atomic. r=kmag,Gankro,decoder
https://hg.mozilla.org/integration/autoland/rev/9e1d4db4e5d0
Cleanup ScriptPreloader Runnable behaviour. r=kmag,Gankro,decoder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.