Closed Bug 1601828 Opened 1 year ago Closed 1 year ago

ubuntu1804 - install compiz

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: egao, Assigned: egao)

References

Details

Attachments

(1 obsolete file)

compiz was previously installed on the ubuntu1604 test image, and it has not been included in the ubuntu1804-test docker image.

Turns out, installing and calling compiz resolves some of the unexplained failures in mochitest-browser-chrome, while causing some other failures.

A majority of the new failures are failures with sheriff annotation on them, with either constant activity or new bug IDs.

One of the issue with installing compiz is that pulseaudio seems to not like the way it is started, in

  • test-linux.sh; then
  • desktop_unittest.py

Leading to a bunch of failures in this push:

[task 2019-12-05T00:07:29.451Z] 00:07:29     INFO -  (gst-launch-1.0:1213): GStreamer-CRITICAL **: 00:07:29.446: gst_object_unref: assertion '((GObject *) object)->ref_count > 0' failed
[task 2019-12-05T00:07:29.451Z] 00:07:29     INFO -  Setting pipeline to NULL ...
[task 2019-12-05T00:07:29.451Z] 00:07:29     INFO -  Freeing pipeline ...
[task 2019-12-05T00:07:29.459Z] 00:07:29     INFO -  Connection failure: Connection refused
[task 2019-12-05T00:07:29.459Z] 00:07:29     INFO -  pa_context_connect() failed: Connection refused
[task 2019-12-05T00:07:29.459Z] 00:07:29     INFO -  Traceback (most recent call last):
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 3163, in <module>
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -      sys.exit(cli())
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 3159, in cli
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -      return run_test_harness(parser, options)
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 3144, in run_test_harness
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -      result = runner.runTests(options)
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 2642, in runTests
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -      res = self.runMochitests(options, tests_in_manifest)
[task 2019-12-05T00:07:29.460Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 2412, in runMochitests
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -      result = self.doTests(options, testsToRun)
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 2703, in doTests
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -      devices = findTestMediaDevices(self.log)
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 820, in findTestMediaDevices
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -      if not null_sink_loaded():
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtests.py", line 817, in null_sink_loaded
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -      [pactl, 'list', 'short', 'modules'])
[task 2019-12-05T00:07:29.461Z] 00:07:29     INFO -    File "/usr/lib/python2.7/subprocess.py", line 223, in check_output
[task 2019-12-05T00:07:29.462Z] 00:07:29     INFO -      raise CalledProcessError(retcode, cmd, output=output)
[task 2019-12-05T00:07:29.462Z] 00:07:29     INFO -  subprocess.CalledProcessError: Command '['/usr/bin/pactl', 'list', 'short', 'modules']' returned non-zero exit status 1
[task 2019-12-05T00:07:29.522Z] 00:07:29    ERROR - Return code: 1
[task 2019-12-05T00:07:29.523Z] 00:07:29    ERROR - No suite end message was emitted by this harness.
[task 2019-12-05T00:07:29.524Z] 00:07:29     INFO - TinderboxPrint: mochitest-mochitest-browser-chrome<br/>38/0/0
[task 2019-12-05T00:07:29.524Z] 00:07:29    ERROR - # TBPL FAILURE #
[task 2019-12-05T00:07:29.524Z] 00:07:29  WARNING - setting return code to 2
Assignee: nobody → egao

I'd say don't install compiz. It's not a realistic setup anymore. If that breaks some tests, the tests should be fixed. Possibly disabled until they are fixed.

Turns out compiz is incompatible with GNOME, but some people have a workaround like so:

https://askubuntu.com/questions/1135793/ubuntu-18-04-gnome-compiz-crash

sudo apt purge gnome-panel gnome-session-flashback compiz compizconfig-settings-manager compiz-plugins
sudo apt autoremove
sudo apt purge $(dpkg -l | grep '^rc' | awk '{print $2}')

reboot

sudo apt install gnome-panel gnome-session-flashback compiz compizconfig-settings-manager compiz-plugin

Now, not sure if this works when I tried to do this on my local virtualbox (virtualbox triggers a kernel panic on macosx1015 frequently).

(In reply to Mike Hommey [:glandium] (high latency) from comment #3)

I'd say don't install compiz. It's not a realistic setup anymore. If that breaks some tests, the tests should be fixed. Possibly disabled until they are fixed.

After spending the good part of this week debugging an issue with how GNOME interacts with marionette, this is a tempting solution even if it may not be a realistic setup.

ubuntu1804 with compiz:
https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedJob=279931126&revision=a5c059e5668e3db07165855f67038f3c8a07866d

ubuntu1804 without compiz:
https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedJob=279931126&revision=e8f1e9e290c6639887b4b8d0a1c4253a5f0d612e

See bug 1600391 for the issues with window.resizeTo and window.moveTo being more async than expected on ubuntu1804. By installing compiz I'm attempting to reproduce the same testing environment as we currently have on ubuntu1604 as per https://bugzilla.mozilla.org/show_bug.cgi?id=1601457#c6.

Why is compiz no longer a realistic setup? Has it lost favor with the userbase, or is it slowly being phased out? If such is the case, then I would agree that relying on this fix just kicks the can down to ubuntu 20.04 or later.

I'm not even sure compiz ever was the default on Ubuntu, but even if it were, it's not the case anymore. Ubuntu users are on GNOME, with mutter/gnome-shell. So testing compiz is very much out of sync with what users have.

Just FYI, I do see a reference to compiz in the test-linux.sh script here:
https://searchfox.org/mozilla-central/source/taskcluster/scripts/tester/test-linux.sh#183

So it is being started on current ubuntu1604 environment, I assume, and the reason for the no top bar, no dock environment (unless I'm horribly mistaken).

On the other hand I understand this fact doesn't change that we should target the most common configuration, which would be running GNOME if ubuntu1804.

Attachment #9114012 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.