bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

animated GIF moves 1px right during animation

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The Join Now button moves right 1px during it's animation, on the 3rd frame or
so. Doesn't happen if I view it directly, or view that page in 4.x.

100% reproducable, across restarts.

Comment 1

16 years ago
hmm. can't see it move on a current CVS build, Linux. (17"/1280x1024/24bpp)
(Reporter)

Comment 2

16 years ago
It's happened in various trunk builds for me, since Apple made that page a month
ago or so.

XFree86 version: 4.1.0
  dimensions:    1152x864 pixels (361x271 millimeters)
  resolution:    81x81 dots per inch
  depth of root window:    16 planes

S3V driver.

Comment 3

16 years ago
worksforme, linux trunk build 20020730, 1280x1024x16bpp, 19" :)

Comment 4

16 years ago
Don't see this with WinXP 2002080408 trunk. There was a similar bug I filed last
year. See bug 51992 for info.
(Reporter)

Comment 5

16 years ago
Seeing massive movement of the Amazon.com "Gold box" image. Each "spark" in the
animation shifts parts of the image all sorts of ways. View image from the
context menu doesn't show any such movement, but on normal pages it happens all
the time.

Looks like another rounding issue. Ugg.

Comment 6

16 years ago
I don't see this with Amazon either. Must be a Linux specific issue.

Comment 7

16 years ago
WFM linux branch build 2002080907 (Both mac.com and the gold box on amazon)

Comment 8

16 years ago
WFM linux trunk build 2002080808 (Both mac.com and the gold box on amazon)

Comment 9

16 years ago
WFM, Aug 5th #8 build.  However I would -not- close this bug as WFM because I
know for a fact there are numerous rounding bugs that are only apparent for 
systems with a given DPI resolution.

Comment 10

16 years ago
Confirmed using 2002080121 (linux; ATI Radeon VE)

On www.mac.com one frame is shifted right. I think it's about the 7th and it's
2px - but just guessing.

Gold box shows without problems here.
(Reporter)

Comment 11

16 years ago
both characters show this at the top of:
  http://www.johndaileysoftware.com/

very distracting and ruins the character illusion.

Updated

16 years ago
Blocks: 119597

Comment 12

15 years ago
Is this still an issue? WFM Gecko/20031114 Firebird/0.7+, Windows XP

Comment 13

15 years ago
I'm seeing this bug in Firebird 0.7 on Linux.  Animations moves parts of the
frame a pixel in any direction for some (but not all) frames.  Sometimes this
results in a "compressed" image (where a horiz. or vert. line is missing), other
times it's an "expanded" image (with a transparent line within).  This rarely
happens at bigger images, but it *always* happens at small animated images
surrounded by text (such as forum emoticons).

Comment 14

14 years ago
Is this bug related to bug 206150?

Comment 15

14 years ago
*** Bug 219294 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
*** Bug 246626 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

14 years ago
I think this may be fixed in the GTK2 builds. I haven't noticed pixel alignment
issues (or any of the font pixel rounding errors) in the GTK2 builds.

Comment 18

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050205
Firefox/1.0+

I can't see problems with either test case, but I suspect that the
mac.com page has changed.

Comment 19

11 years ago
mac.com page has changed, but also the image handling code has been replaced by Cairo, so this problem no longer applies.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.