Closed Bug 1602193 Opened 2 years ago Closed 2 years ago

selected imap folder not highlighted - starting with 72.0b1

Categories

(Core :: Widget: Cocoa, defect, P1)

72 Branch
All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 + fixed
firefox73 + fixed
firefox74 + fixed
firefox75 --- fixed

People

(Reporter: sbrandle, Assigned: mstange)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

Steps to reproduce:

Click on any folder on either an IMAP or POP server.

Actual results:

Messages are displayed as expected, but there is no visual indication in the folder list down the left as to which folder's messages are being displayed.

Expected results:

Until -- I think -- the 72.0b1 release, the selected folder was visually distinguished in the folder list on the left, thus providing a reminder as to which folder's messages are being displayed.

Component: Folder and Message Lists → Theme
Keywords: regression
Assignee: nobody → richard.marti

Markus, I see this in FX's sidebar too when a LW-theme (not one that styles trees) is active. I think this is a regression from bug 1592739 too.

Flags: needinfo?(mstange)

I can reproduce this.

Assignee: richard.marti → mstange
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mstange)
Regressed by: 1592739
Component: Theme → Widget: Cocoa
OS: Unspecified → macOS
Priority: -- → P3
Product: Thunderbird → Core
Hardware: Unspecified → All
Version: 72 → 72 Branch

[Tracking Requested - why for this release]: Regression that makes some text unreadable when certain themes are used

Is bug 1493789 something that can be looked at at the same time ?

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1
Duplicate of this bug: 1602598

Markus, are you able to investigate this bug for 73/74? Thanks!

Flags: needinfo?(mstange)

As of the Thunderbird 72.0b3 (64-bit) update a few days ago, the problem is resolved for me. Selected folder display is working correctly.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mstange)
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

The bug is back in 74.0b1 (64-bit).

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

74.0b1 didn't have the fix, it landed for 74.0b3.

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.