Closed Bug 1602293 Opened 11 months ago Closed 11 months ago

Extension Block Request: S3.Translator-Clone

Categories

(Toolkit :: Blocklist Policy Requests, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: d4752484, Assigned: TheOne)

Details

Extension name S3.Translator-Clone
Extension versions affected <all versions>
Platforms affected <all platforms>
Block severity soft

Reason

"Note; This is clone version of original S3.Translator."

S3.Translator. was removed because it offer (optional) to send every visited URL to 3rd-party server. "Clone" does it too.

Extension IDs

{3a2831f6-37df-4a42-baf6-0b81d5b6a68f}

I’ve reviewed the add-ons and confirmed they are collecting ancillary user data against our policies.

Assignee: nobody → awagner
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

The block has been pushed.

Group: blocklist-requests
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

(In reply to Andreas Wagner [:TheOne] [use NI] from comment #2)

The block has been pushed.

I really need this addon, it is the ONLY one that allows you to translate entire pages using your own cookies as you would chrome. I am using the original that was deleted by that optional feature (which requires affirmative consent) and not any clone, however it was banned and now my browser does not allow me to re-activate it.

Is there any reason why it should suffer such a severe blocking if nothing has changed? I would like to invite you to block it again in the soft way.

In case for some reason you prefer to continue unjustly treating it as malware, could you or someone tell me how to skip this hard block so that I can continue using firefox? Thanks.

Hi Mike, while I appreciate your intention to help, we're not keen on helping people override the blocklist as it helps us protect their privacy and security. To that effect, we've hidden your comment with instructions for blocklist circumvention (which you are of course free to publish on your own forum, although we explicitly do not recommend that people disable the blocklist).

I need this complement, it is the only one that is really useful in the browser, firefix has no other complement that can be compared, I ask for a solution for those who if we use S3.Translator, it was difficult not to find it in firefox add-ons by the same reasons, that there is no other complement than a close performance.

I know this is probably not the right place to discuss this, but it really seems like the policies need to be updated to allow the end-user to decide how to use Firefox. There seems to be a trend in disallowing extensions that allow a user to perform tasks that Firefox doesn't support by default (e.g. Tridactyl and this extension), which begs the question why extensions are even allowed any more?
Could we please get a way to continue to use extensions even if they are deemed incompatible with the policies?

On a personal note, as an expat I really do need my browser of choice to let me translate pages and after the recent Tridactyl mess and now this, it really feels as if Mozilla/Firefox is becoming determined to not work with me as an end-user but against me.

Thank you all for the comments, however, this is not a discussion forum and the work on this bug has been completed. For discussions, please use discourse.mozilla.org/c/add-ons/

Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.