Closed Bug 1602396 Opened 3 years ago Closed 11 months ago

Firefox loses input focus from the address bar when a new tab is detached.

Categories

(Firefox :: Address Bar, defect, P3)

71 Branch
Desktop
Windows 10
defect
Points:
3

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox-esr68 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox91 --- verified

People

(Reporter: bugzilla_admin, Assigned: daisuke)

References

Details

(Keywords: papercut)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

I have multiple monitors. When I want a new FireFox window open on one of the other monitors, I create a new tab, and drag the tab to another monitor, and then try to type an address or words to search.

Actual results:

Keystrokes are lost because when a tab is detached, the input focus is lost from the address bar.

Expected results:

This is annoying for me. If you see the attached video, only FireFox behaves this way. I used the on-screen keyboard to show that I am typing. When I create a new tab on FireFox, the address bar gets the input focus and I can start typing. If I create a new tab and detach it, the address bar no longer has the input focus.

Now, I tried the same thing with Chrome and Edge. Both had the input focus on the address bar when a new tab is created, and both kept the input focus on the address bar when the tab was detached.

Component: Untriaged → New Tab Page
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Summary: Firefox loses input focus from the address bar when detached. → Firefox loses input focus from the address bar when a new tab is detached.

This probably belongs in another component. This to me feels like an issue with the address bad or tab switching code. Not sure which component those features belong to yet. I'll see if I can find something.

Newtab is mostly concerned with the contents and rendering of a newtab.

You can also reproduce this bug with any webpage, not just a newtab.

I'm taking a guess on the component here :)

Component: New Tab Page → Address Bar

could you please find a regression range for this bug using mozregression? Provided it's not there from a long time.

Type: enhancement → defect

I have attempted to regress this issue, but I went as far as Firefox 40 and it still reproduces. It is definitely not a recent regression, probably not even a regression at all.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Thank you a lot!

Priority: -- → P3
Severity: normal → S3
Keywords: papercut
Points: --- → 3
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/40a3655f471e
Set focus to URLBar when an empty tab is moved to new window. r=adw
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Reproduced the issue on Fx Nightly 89.0a1, verified the issues as fixed with Firefox 91.0a1 (2021-07-01) with Windows 10x64 with two monitors.

Status: RESOLVED → VERIFIED
See Also: → 1743212
You need to log in before you can comment on or make changes to this bug.