Closed Bug 1602444 Opened 11 months ago Closed 11 months ago

The OBT debugger pauses twice on breakpoints in content

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: pbro, Assigned: ochameau)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

Steps:

At this point, the content debugger pauses, and the pause overlay appears, which is fine.

  • Resume execution from the content debugger.

Now the OBT debugger pauses which is ... probably fine. But the pause overlay does not appear!

  • Resume execution from the OBT debugger.

Now the pause overlay appears, even though the OBT debugger does not show the resume icon anymore.

I tested again without the content toolbox.

Steps:

==> The OBT debugger pauses, but the pause overlay does not appear. After clicking resume, it does appear, and you have to click resume in the overlay itself to really resume execution.

This is probably the right scenario to focus on here.

Summary: The content debugger pauses multiple times when both the content toolbox and OBT are opened → The OBT debugger pauses twice on breakpoints in content

I can confirm, I can easily reproduce both scenarios on my machine (Win10, Fx Nightly 73)
Honza

We were breaking twice in the browser toolbox because we were attaching to
all the content process targets as well as all frame targets.
But as frames (i.e. web pages) are running within the content processes,
we were having two thread actor attached to the same thread.
This is a stopgap solution for the browser toolbox and we would need
to do something better for the content toolboxes.

Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Blocks: 1605326
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/77064d142ac5
Prevent attaching twice to content pages from the browser toolbox. r=jdescottes
Blocks: 1605393
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
You need to log in before you can comment on or make changes to this bug.