Closed Bug 1602584 Opened 7 months ago Closed 7 months ago

Intermittent /builds/worker/workspace/build/tests/mozmill/folder-display/test-message-commands-on-msgstore.js | test-message-commands-on-msgstore.js::test_mark_messages_replied, test_mark_messages_forwarded

Categories

(Thunderbird :: Folder and Message Lists, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 73.0

People

(Reporter: intermittent-bug-filer, Assigned: mkmelin)

References

Details

(Keywords: intermittent-failure)

See Also: → 1133957
Duplicate of this bug: 1604702
Summary: Intermittent /builds/worker/workspace/build/tests/mozmill/folder-display/test-message-commands-on-msgstore.js | test-message-commands-on-msgstore.js::test_mark_messages_forwarded → Intermittent /builds/worker/workspace/build/tests/mozmill/folder-display/test-message-commands-on-msgstore.js | test-message-commands-on-msgstore.js::test_mark_messages_replied, test_mark_messages_forwarded

What's the plan here? How can a test failure be P5? IMHO, it should be P1. Do you want to go around starring the tree forever or maybe just disable the test? This doesn't look intermittent either, so why didn't you record a regression range when filing the bug? Do you know what caused it? How do you expect to find it weeks down the track?

Besides, this looks the same as bug 1604187.

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)

Re priority, that's just how treeherder files them.
Yes this is basically the same as bug 1604187. (I think). This one we probably won't be fixing since mozmill is going away. Bug 1604187. would be the one to look into. But as long as mozmill is with us, we can have this open so treeherder can tell you it's a known thing.

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)

Why don't you just disable it then? Pretty annoying to look at the failure every time, especially for people testing patches on try who need to know to ignore it. "Known things" are recorded here: https://mzl.la/2T5ZJz6.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4f56e93d5324
disable failing test-message-commands-on-msgstore.js mozmill tests. rs=bustage-fix

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Disabled now. I think we can call this fixed, with bug 1604187 to follow up with the "real" fix.

Assignee: nobody → mkmelin+mozilla
Target Milestone: --- → Thunderbird 73.0

That's not how you disable a test on all platforms :-( - You use:
test_XXX.force_skip = true;
https://searchfox.org/comm-central/search?q=__force_skip__+%3D+true%3B&case=false&regexp=false&path=

Sigh.

It's not like it matters.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d8d88f20aa20
Follow-up: Use __force_skip__ for disabling on all platforms. r=me

Consistency is an aspect of quality, and IMHO it does matter. Why do we use clang-format and prettier/linting to enforce consistency of white-space distribution?

Sure, but like you know, the code in question will be completely removed real soon now.

You need to log in before you can comment on or make changes to this bug.