If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

large cert database crashes NSS 3.6

VERIFIED DUPLICATE of bug 155704

Status

NSS
Libraries
P1
normal
VERIFIED DUPLICATE of bug 155704
15 years ago
15 years ago

People

(Reporter: Julien Pierre, Assigned: Robert Relyea)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
1) Download my large cert database (in ZIP format) from
http://bugzilla.mozilla.org/attachment.cgi?id=66522&action=view 

2) do certutil -d . -L

3) crash

current thread: t@1
=>[1] nss_ZRealloc(pointer = 0xffbef5c8, newSize = 128U), line 1084 in "arena.c"
  [2] find_objects(tok = 0x8ddf8, sessionOpt = (nil), obj_template = 0xffbef700,
otsize = 2U, maximumOpt = 0, statusOpt = 0xffbef7a8), line 447 in "devtoken.c"
  [3] find_objects_by_template(token = 0x8ddf8, sessionOpt = (nil), obj_template
= 0xffbef700, otsize = 2U, maximumOpt = 0, statusOpt = 0xffbef7a8), line 519 in
"devtoken.c"
  [4] nssToken_FindCertificates(token = 0x8ddf8, sessionOpt = (nil), searchType
= nssTokenSearchType_TokenOnly, maximumOpt = 0, statusOpt = 0xffbef7a8), line
653 in "devtoken.c"
  [5] PK11_TraverseCertsInSlot(slot = 0x8c018, callback = 0xff1b77c8 =
&`libnss3.so`pk11cert.c`listCertsCallback(struct CERTCertificateStr *cert, void
*arg), arg = 0x90280), line 2807 in "pk11cert.c"
  [6] PK11_ListCertsInSlot(slot = 0x8c018), line 3448 in "pk11cert.c"
  [7] listCerts(handle = 0x85500, name = (nil), slot = 0x8c018, raw = 0, ascii =
0, outfile = 0x637a8, pwarg = 0xffbefa0c), line 603 in "certutil.c"
  [8] ListCerts(handle = 0x85500, name = (nil), slot = 0x8c018, raw = 0, ascii =
0, outfile = 0x637a8, pwdata = 0xffbefa0c), line 640 in "certutil.c"
  [9] main(argc = 4, argv = 0xffbefac4), line 2530 in "certutil.c"
(dbx)
(Reporter)

Updated

15 years ago
Priority: -- → P1
Target Milestone: --- → 3.6
(Reporter)

Comment 1

15 years ago
Bob,

FYI, I still see this crash with NSS 3.6 even with my key3.db.

Comment 2

15 years ago
Assigned the bug to Bob.
Assignee: wtc → relyea
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 155704 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.