http://www.gotfuturama.com/ crashes Mozilla [@ js_IsAboutToBeFinalized] [@ ntdll.dll]

VERIFIED DUPLICATE of bug 158098

Status

()

Core
XPConnect
--
critical
VERIFIED DUPLICATE of bug 158098
16 years ago
16 years ago

People

(Reporter: Kai Stukenbrock, Assigned: David Bradley)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
Opening this site crashes Mozilla. Allways reproducible on my system: Mozilla
2002073019 on Win2k.

Comment 1

16 years ago
worksforme: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Comment 2

16 years ago
wfm using build 2002073004 on Win2k (trunk).
Kai, do you get a Talkback window popup when crashing ? If so, please post
Talkback ID for this crash by running 'mozilla/bin/components/talkback.exe'.
Severity: major → critical
Keywords: crash, stackwanted
(Reporter)

Comment 3

16 years ago
Talback ID is TB8840307W.
I just had a case where I could open the page...

I figure that maybe it has something to do with the page I'm coming from.
http://www.spiegel.de ist my homepage coming up on browser start. When going to
the indicated site afterwards, my browser crashes.

Comment 4

16 years ago
I tried to go to www.gotfuturama.com after visiting www.spiegel.de and also had
mozilla crashing. I´m using Build 2002072408 (trunk) on Windows XP. The
Talkback-ID is TB8841126Z.

Comment 5

16 years ago
I did something else. I first loaded www.gotfuturama.com. It all loaded okay. I
then reloaded the page and bam, Mozilla crashed. Here is the talkback id: TB8841212X

OS: Win XP
Build: 20020718

Comment 6

16 years ago
Crashed mine too:  1.1b (2002072204) on Win2K.
TB8846259K

I only had a few Bugzilla tabs open, and pasted the url into the url field on a
new tab.  Moz displayed the page, paused briefly, then crashed.

IE 5.0 works find.  In Netscape 4.78 page loading activity appears to stop, but
NS displays only the title text and a black page, hangs (unresponsive) for ~10
seconds, then displays the rest of the page.

Comment 7

16 years ago
I posted this in bug #159500 a few days ago, maybe it helps:

The site uses some little tricks with gzipped shipping of the HTML, maybe 
that's a problem? What's happening there is: 

1. checks $ENV{'HTTP_ACCEPT_ENCODING'}=~/gzip/
2. gzips html into temporary file 
3. tells apache to send the gzipped file instead
4. sets Header Content-Encoding gzip

Try http://www.gotfuturama.com/index.shtml to get it without the gzipping. If 
that crashes, too it should be some HTML parsing problem.

mArc (site owner)

Comment 8

16 years ago
Incident #8840307
------------------
Product ID MozillaTrunk
Build ID 2002072408
Operating System Windows NT 5.1 build 2600
User Comments Going to www.gotfuturama.com after visiting www.spiegel.de

Stack Trace
nsCellMap::~nsCellMap
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsCellMap.cpp, line 976]
nsTableCellMap::~nsTableCellMap
[c:/builds/seamonkey/mozilla/layout/html/table/src/nsCellMap.cpp, line 114]
nsTableFrame::`scalar deleting destructor'
nsFrame::Destroy [c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrame.cpp,
line 489]
gklayout.dll + 0xe3e90 (0x607f3e90)
PresShellViewEventListener::AddRef
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 7236]

Incident #8846259, and 8841212
--------------------
Product ID MozillaTrunk
Build ID 2002072204
Operating System Windows NT 5.0 build 2195
URL visited http://www.gotfuturama.com
User Comments testing bug 160283. Had a couple bugzilla tabs open. Created new
tab, pasted url, it displayed the page, paused very briefly and crashed.

Stack Trace
js_IsAboutToBeFinalized [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 223]
XPCNativeMember::DealWithDyingGCThings
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcprivate.h, line 1089]
NativeInterfaceGC
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcjsruntime.cpp, line 103]
JS_DHashTableEnumerate [c:/builds/seamonkey/mozilla/js/src/jsdhash.c, line 601]
XPCJSRuntime::GCCallback
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcjsruntime.cpp, line 294]
js_GC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 1266]
js_ForceGC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 986]
JS_GC [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 1657]
nsJSContext::Notify
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1599]
nsTimerManager::FireNextIdleTimer
[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp, line 588]
nsAppShell::Run [c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp,
line 134]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1527]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1874] 
Keywords: stackwanted
Summary: http://www.gotfuturama.com/ crashes Mozilla → http://www.gotfuturama.com/ crashes Mozilla [@ js_IsAboutToBeFinalized] [@ ntdll.dll]
(Reporter)

Comment 9

16 years ago
Must be a parsing problem then, as
http://www.gotfuturama.com/index.shtml
also crashes my Mozilla, coming from http://www.spiegel.de
(opening the page in a new tab worked fine, though...)

Should this be marked as a dup of bug #159500? On the other hand, this bug has
more input (comments).

Comment 10

16 years ago
I got it to crash just by opening URL in new tab Talkback IS TB8851486M

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

16 years ago
Marking as regression as it doesn't happen in BuildID 2002060208 but does happen
in BuildID 2002061408 both trunk builds on WinXP
Keywords: regression

Comment 12

16 years ago
*** Bug 159500 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Bug 159500 narrows the regression down to between buildIDs 2002060208 and 2002061104

Comment 14

16 years ago
worksforme, linux trunk build 20020730
-> Xp Connect
Assignee: Matti → dbradley
Component: Browser-General → XPConnect
QA Contact: asa → pschwartau
(Assignee)

Comment 16

16 years ago
This is caused by the same buffer overrun in gfxImageFrame::SetAlphaData that
bug 158098 is caused by

*** This bug has been marked as a duplicate of 158098 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
/me sucks
Status: RESOLVED → VERIFIED
Crash Signature: [@ js_IsAboutToBeFinalized] [@ ntdll.dll]
You need to log in before you can comment on or make changes to this bug.