Closed Bug 1602831 Opened 1 year ago Closed 1 year ago

Intermittent org.mozilla.geckoview.test.crash.CrashTest.crashContent | status -2

Categories

(GeckoView :: General, defect, P5)

Unspecified
All
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1600658

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=280501565&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/V6GD_aqhTAyL4LPyL-WMFw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=crashContent
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.crash.CrashTest
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=java.lang.AssertionError: Fatality should match
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | Expected: <false>
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | but: was <true>
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.hamcrest.MatcherAssert.assertThat(MatcherAssert.java:20)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertThat(Assert.java:956)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.crash.CrashTest.assertCrashIntent(CrashTest.kt:52)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.crash.CrashTest.crashContent(CrashTest.kt:72)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.internal.runner.junit4.statement.RunBefores.evaluate(RunBefores.java:80)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.rule.ServiceTestRule$ServiceStatement.evaluate(ServiceTestRule.java:335)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.rules.RunRules.evaluate(RunRules.java:20)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:325)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:78)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:57)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:71)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:288)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.access$000(ParentRunner.java:58)
[task 2019-12-10T16:34:30.211Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:268)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.runner.AndroidJUnit4.run(AndroidJUnit4.java:101)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.Suite.runChild(Suite.java:128)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.Suite.runChild(Suite.java:27)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:71)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:288)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.access$000(ParentRunner.java:58)
[task 2019-12-10T16:34:30.212Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:268)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runner.JUnitCore.run(JUnitCore.java:137)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runner.JUnitCore.run(JUnitCore.java:115)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.internal.runner.TestExecutor.execute(TestExecutor.java:56)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.runner.AndroidJUnitRunner.onStart(AndroidJUnitRunner.java:384)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1932)
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test |
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=596
[task 2019-12-10T16:34:30.213Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2019-12-10T16:34:30.214Z] 16:34:30 WARNING - TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.crash.CrashTest.crashContent | status -2
[task 2019-12-10T16:34:30.214Z] 16:34:30 INFO - TEST-INFO took 7114ms
[task 2019-12-10T16:34:30.310Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_RESULT: stream=
[task 2019-12-10T16:34:30.310Z] 16:34:30 INFO - org.mozilla.geckoview.test |
[task 2019-12-10T16:34:30.310Z] 16:34:30 INFO - org.mozilla.geckoview.test | Time: 253.415
[task 2019-12-10T16:34:30.310Z] 16:34:30 INFO - org.mozilla.geckoview.test | There was 1 failure:
[task 2019-12-10T16:34:30.310Z] 16:34:30 INFO - org.mozilla.geckoview.test | 1) crashContent(org.mozilla.geckoview.test.crash.CrashTest)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | java.lang.AssertionError: Fatality should match
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | Expected: <false>
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | but: was <true>
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.hamcrest.MatcherAssert.assertThat(MatcherAssert.java:20)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertThat(Assert.java:956)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.crash.CrashTest.assertCrashIntent(CrashTest.kt:52)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.crash.CrashTest.crashContent(CrashTest.kt:72)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2019-12-10T16:34:30.311Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.internal.runner.junit4.statement.RunBefores.evaluate(RunBefores.java:80)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.rule.ServiceTestRule$ServiceStatement.evaluate(ServiceTestRule.java:335)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.rules.RunRules.evaluate(RunRules.java:20)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:325)
[task 2019-12-10T16:34:30.312Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:78)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:57)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:71)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:288)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.access$000(ParentRunner.java:58)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:268)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
[task 2019-12-10T16:34:30.313Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.runner.AndroidJUnit4.run(AndroidJUnit4.java:101)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.Suite.runChild(Suite.java:128)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.Suite.runChild(Suite.java:27)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:71)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:288)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.access$000(ParentRunner.java:58)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:268)
[task 2019-12-10T16:34:30.314Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
[task 2019-12-10T16:34:30.315Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runner.JUnitCore.run(JUnitCore.java:137)
[task 2019-12-10T16:34:30.315Z] 16:34:30 INFO - org.mozilla.geckoview.test | at org.junit.runner.JUnitCore.run(JUnitCore.java:115)
[task 2019-12-10T16:34:30.315Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.internal.runner.TestExecutor.execute(TestExecutor.java:56)
[task 2019-12-10T16:34:30.315Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.support.test.runner.AndroidJUnitRunner.onStart(AndroidJUnitRunner.java:384)
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1932)
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test |
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test | FAILURES!!!
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test | Tests run: 574, Failures: 1
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test |
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test |
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_CODE: -1
[task 2019-12-10T16:34:30.316Z] 16:34:30 INFO - Passed: 526
[task 2019-12-10T16:34:30.316Z] 16:34:30 WARNING - Failed: 1
[task 2019-12-10T16:34:30.317Z] 16:34:30 WARNING - One or more unittests failed.
[task 2019-12-10T16:34:30.317Z] 16:34:30 INFO - Todo: 69
[task 2019-12-10T16:34:30.317Z] 16:34:30 INFO - SUITE-END | took 255s
[task 2019-12-10T16:34:30.942Z] 16:34:30 INFO - Stopping web server
[task 2019-12-10T16:34:30.945Z] 16:34:30 INFO - Stopping web socket server
[task 2019-12-10T16:34:30.965Z] 16:34:30 INFO - Stopping ssltunnel
[task 2019-12-10T16:34:31.662Z] 16:34:31 ERROR - Return code: 1
[task 2019-12-10T16:34:31.662Z] 16:34:31 INFO - TinderboxPrint: geckoview-junit<br/>526/<em class="testfail">1</em>
[task 2019-12-10T16:34:31.662Z] 16:34:31 INFO - ##### geckoview-junit log ends
[task 2019-12-10T16:34:31.662Z] 16:34:31 WARNING - # TBPL WARNING #
[task 2019-12-10T16:34:31.662Z] 16:34:31 WARNING - setting return code to 1
[task 2019-12-10T16:34:31.662Z] 16:34:31 WARNING - The geckoview-junit suite: geckoview-junit ran with return status: WARNING
[task 2019-12-10T16:34:31.662Z] 16:34:31 INFO - Running post-action listener: _package_coverage_data

I expect this to be fixed by bug 1600658 when it lands.

Depends on: 1600658
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1600658
You need to log in before you can comment on or make changes to this bug.