Closed Bug 1602840 Opened 4 months ago Closed 2 months ago

Add new bitflag preference that prevents adding new sideload addons

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

No description provided.
Assignee: nobody → mixedpuppy
Priority: -- → P1
Attachment #9116801 - Attachment description: Bug 1602840 don't sideload when rebuilding XPI database → Bug 1602840 test that we don't sideload when rebuilding XPI database
Pushed by dvarga@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/5ad4c0f6c5db
add build switch for sideloading addons r=zombie
https://hg.mozilla.org/mozilla-central/rev/bc6122544852
add pref to disable adding new sideloaded addons r=aswan,zombie
https://hg.mozilla.org/mozilla-central/rev/faa15c6fed65
test that we don't sideload when rebuilding XPI database r=zombie,aswan
Duplicate of this bug: 1608325

Just an FYI...this hasn't landed yet due to fighting with a couple test failures on linux.

Flags: needinfo?(mixedpuppy)
Blocks: 1613268
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/acbb75628d35
add build switch for sideloading addons r=zombie
https://hg.mozilla.org/integration/autoland/rev/7d4df29b69ba
add pref to disable adding new sideloaded addons r=aswan,zombie
https://hg.mozilla.org/integration/autoland/rev/5972260469ab
test that we don't sideload when rebuilding XPI database r=zombie,aswan
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.