Closed Bug 1602941 Opened 7 months ago Closed 7 months ago

tooltip which pops up when hovering over a folder with unread messages partially unreadable

Categories

(Thunderbird :: Theme, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68 fixed, thunderbird72 fixed, thunderbird73 fixed)

RESOLVED FIXED
Thunderbird 73.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird72 --- fixed
thunderbird73 --- fixed

People

(Reporter: dheddicke, Assigned: Paenglab)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

Hover with cursor over a folder with unread messages

Actual results:

A tooltip pops up which shows the subjects and a part of the content of the email, but the content isn't readable.

Expected results:

The tooltip should pop up and the subjects and the content should be readable

The problem appears under Debian 10 with KDE5 as environment

Did you make sure to try with the standard theme? Looks like some text color is off.

Component: Folder and Message Lists → Theme

The only that i use, is the breeze-gtk-theme, for better integration with kde. It's set via the system settings (kde-config-gtk-style module).
I thought that it did work in version 68 but i tested tested it again and it doesn't work in 68 too.
Sorry, if thats not a problem of thunderbird. I'll try try to change the color by myself.

It seems KDE doesn't set the GrayText correctly.
Instead of defining a fixed colour, I use a reduced opacity. With this we always use the text colour that should fit in the tooltip also with exotic tooltip colours.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9115372 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9115372 [details] [diff] [review]
1602941-tooltip-summary-preview.patch

Review of attachment 9115372 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thx! r=mkmelin
Attachment #9115372 - Flags: review?(mkmelin+mozilla) → review+
Attachment #9115372 - Flags: approval-comm-esr68?
Attachment #9115372 - Flags: approval-comm-beta?

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3d204edf74ac
Use for the folder tooltip summary text a reduced opacity instead of a fixed colour. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 73.0
Comment on attachment 9115372 [details] [diff] [review]
1602941-tooltip-summary-preview.patch

[Triage Comment]
Attachment #9115372 - Flags: approval-comm-beta? → approval-comm-beta+
Target Milestone: Thunderbird 73.0 → Thunderbird 72.0
Target Milestone: Thunderbird 72.0 → Thunderbird 73.0
Attachment #9115372 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.