chatzilla doesn't display nicknames in userlist when the channel name contains some national characters

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: lukasz, Assigned: rginda)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patched)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

I have encountered this bug at irc://ircnet/#chojnów - chatzilla doesn't display
nicknames in any channel containing ó in the name; other national  characters
make no difference.

Reproducible: Always
Steps to Reproduce:
1. connect to some ircnet server 
2. /join #chojnów. If you can't enter ó on your keyboard you can go to #chojnow
and cut&paste the name from the topic - it is always there.


Actual Results:  The nickname list isn't showed.

Expected Results:  Chatzilla shall show them.
Confirmed using 2002072404 - Win2k SP2

Don't see any nicks in the list, but nick-completion works.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
I encountered the same problem in a channel with no national-character in the
channel-name.

Comment 3

17 years ago
*** Bug 177935 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
*** Bug 169778 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
I think nsScriptableUnicodeConverter::ConvertFromUnicode() can't handle
8 bit characters correctly.

If channel name is in iso-2022-jp(7 bit), nicknames are displayed.
Severity: normal → major
Keywords: intl
OS: Windows 98 → All
Hardware: PC → All

Comment 6

16 years ago
Does anyone know where this is falling over? I can do /names for the channel
fine, even though it's not showing the user list.

Comment 7

16 years ago
*** Bug 133289 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 190568

Updated

16 years ago
No longer depends on: 190568

Comment 8

16 years ago
Created attachment 116274 [details] [diff] [review]
rough and ready fix

This fixes the problem by escaping the name of the channel before passing it to
rdf.GetResource().  escape() may not be the best thing to use, but it works,
and should help somebody write a 'proper' fix - at least it shows where the
problem lies.

Comment 9

16 years ago
*** Bug 188685 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Whiteboard: cz-patched
(Assignee)

Comment 10

16 years ago
Changes are available in the 0.8.24 XPI on http://www.hacksrus.com/~ginda/chatzilla.

Comment 11

16 years ago
Seems to be fixed in 0.8.24.
(Assignee)

Updated

16 years ago
Depends on: 197108

Comment 12

16 years ago
2003040105-trunk/Linux works fine. Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications

Comment 13

11 years ago
ChatZilla 0.9.79 [Firefox 3.0b3pre/2008011105, WinXP Pro SP2]:
* Userlist doesn't display any usernames in any (moznet-)channel

Restating and playing with color schemes didn't help.
You need to log in before you can comment on or make changes to this bug.