Closed Bug 1603057 Opened 3 years ago Closed 3 years ago

Spellchecking broken in contenteditable documents for special characters

Categories

(Core :: Spelling checker, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1602526

People

(Reporter: listenleser, Unassigned)

Details

Attachments

(2 files)

Attached file Test HTML file

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

  1. Install https://addons.mozilla.org/de/firefox/addon/german-dictionary/
  2. Open the attached HTML file (which has lang=de and is contenteditable=true).
  3. Place the cursor at the end of the list item and type " a für".

Actual results:

The second to last "für" is partially highlighted as wrongly spelled, like there is a word break between "f" and "ür" (see screenshot).
Moving the focus away and back again fixes this, but entering more repetitions of " a für" will show the issue again.

Expected results:

"für" should be treated as one word and not be highlighted as wrongly spelled.

Attached image Screenshot

I don't know how reliably my above steps reproduce the issue, so if you can't, try instead editing a page with the VisualEditor on German Wikipedia (where I originally encountered this issue), this seems to much more reliably to reproduce.
So instead of step 2, you could open https://de.wikipedia.org/wiki/Wikipedia:Spielwiese?veaction=edit, and just edit a bit. But of course that's far from a minimal example.

thanks for filing this with a reproducible testcase. we already have bug 1603057 open for this, so i'll dupe it over.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Untriaged → Spelling checker
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1602526
You need to log in before you can comment on or make changes to this bug.