Closed Bug 1603227 Opened 4 months ago Closed 2 months ago

Enable removing sideloaded extensions

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla74
Tracking Status
firefox74 --- verified

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Enable the ability to remove sideloaded extensions from firefox, but don't remove the addon file if it is not in the profile.

Priority: -- → P1

Backed out for xpcshell perma fails on test_registry.js.

See https://bugzilla.mozilla.org/show_bug.cgi?id=1602840#c5

Pushed by dvarga@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/02d52e2e7d62
enable removing sideloaded extensions from Firefox r=zombie
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9187e110c0e5
enable removing sideloaded extensions from Firefox r=aswan,zombie
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Hello,

Verified the fix using the latest Beta (74.0b4/20200216164042) under Windows 10 Pro 64-bit, macOS Catalina 10.5 and Ubuntu 16.04 LTS.

Sideloaded extensions can now be properly removed via Add-ons Manager (using the Remove option from each individual add-on).
Add-ons sideloaded in the profile folder will be deleted from the folder if removed via Add-ons Manager. Add-ons sideloaded in other locations will not be deleted, as intended.

However, in the case of add-ons sideloaded in the installation directory of the browser (Firefox main folder → browser → extensions), the option to remove the add-ons from Add-ons Manager is not available. Clicking the three-dot menu will not display an option to remove the add-on, but instead the “Can’t Be Removed Why?” option is present.

Is this the intended behavior of this particular sideloading location (installation directory) ?

Flags: needinfo?(mixedpuppy)

(In reply to Alex Cornestean from comment #12)

However, in the case of add-ons sideloaded in the installation directory of the browser (Firefox main folder → browser → extensions), the option to remove the add-ons from Add-ons Manager is not available. Clicking the three-dot menu will not display an option to remove the add-on, but instead the “Can’t Be Removed Why?” option is present.

Is this the intended behavior of this particular sideloading location (installation directory) ?

Are you able to sideload into that location in 74? If so, that is a bug that needs to be fixed.

If it is a sideload installed prior to 74 that continues to work in 74, I think it should be removable (TBD, possibly just remove it automatically), but that can be a followup bug (please post one blocking this one).

Flags: needinfo?(mixedpuppy) → needinfo?(alexandru.cornestean)
Depends on: 1616546

Hello,

As requested, I've filed two issues:
1616545 - add-ons can still be sideloaded in the installation directory in both FX74 and FX75
1616546 - add-ons sideloaded in the installation directory prior to FX74 and FX75 cannot be removed via Add-ons Manager after updating the browser to the latest version

Flags: needinfo?(alexandru.cornestean)

Verified as Fixed on the latest Beta (74.0b8/20200226031638) under Windows 10 Pro 64-bit, macOS Catalina 10.15 and Ubuntu 16.04 LTS.

Sideloaded extensions can now be properly removed from Firefox via Add-ons Manager. Outside the profile add-on files are not removed, while profile add-on files are removed, as intended.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.