Closed Bug 1603352 Opened 4 months ago Closed 27 days ago

About:addons gear button's menu reappears after clicking on the button again

Categories

(Toolkit :: Add-ons Manager, defect, P2)

72 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: Fanolian+BMO, Assigned: mstriemer, Mentored)

References

(Regression)

Details

(Keywords: nightly-community, regression, reproducible)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0
Build ID: 20191211214629

Steps to reproduce

  1. Open about:addons.
  2. Click on the gear button on the right so the menu is activated.
  3. Click on the button again.

Actual result

The menu is closed at mousedown but reappears at mouseup.

Expected result

The menu should stay closed at mouseup like how other buttons work, e.g. hamburger menu, Library button, etc..

The button on the card is using the mousedown listener, this button should be updated to match that. I'll likely get to this eventually but happy to help if someone else wants to take a stab at it.

Assignee: nobody → mstriemer
Mentor: mstriemer
Priority: -- → P2

Happy to take a patch for 74 but I'm marking this fix-optional to remove it from weekly triage since Mark has it on his radar.

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:mstriemer, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mstriemer)
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8332102020cf
Open about:addons gear menu on mousedown r=rpl
Flags: needinfo?(mstriemer)
Status: NEW → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.