Closed Bug 1603380 Opened 4 months ago Closed 2 months ago

Search broken when filtering for more than one string status

Categories

(Webtools :: Pontoon, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Assigned: jotes)

Details

Priority: -- → P1
Assignee: nobody → poke
Status: NEW → ASSIGNED

This looks like a performance issue. The frontend tries to fetch entities (via /get-entities/) and the backend throw an HTTP 503 error after 30 seconds of waiting.
Unfortunately, I don't know what's the root cause of that bottleneck (my first picks: a missing database index, a strange ORM query?). I'll investigate it over the next 2-3 days.

Okay, may current notes:

  • The problem is fully reproducible on Staging (which is good, because it's safer to enable all debug stuff there)
  • Translate.next doesn't currently handle the case on which the server doesn't respond or returns an error
    • :mathjazz :adrian: Do you have an idea how to solve this from the UI perspective?
  • Does Pontoon sends reports about such errors (that are affecting the UI) to New Relic? It could detect such issues sooner.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.