Closed Bug 1604003 Opened 1 year ago Closed 1 year ago

Copy Image fails if image open in other than initial tab

Categories

(Core :: DOM: Core & HTML, defect)

73 Branch
Desktop
Windows 10
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla74
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 blocking verified
firefox74 --- verified

People

(Reporter: alice0775, Assigned: kmag)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

[Tracking Requested - why for this release]: Copy image is broken

Reproducible: 100%
I can reproduce the issue on Nightly73.0a1 Windows10.

Steps to reproduce:

  1. Open 2nd new tab (if initial tab, it will work as expected)
  2. Open url
    e.g,
    https://www.mozilla.org/media/contentcards/img/home-2019/card_1/master.b8b7b1df67c3.png
    https://instagram.fkix2-2.fna.fbcdn.net/v/t51.2885-15/e35/s1080x1080/73420156_338522087022757_5772153876693562840_n.jpg?_nc_ht=instagram.fkix2-2.fna.fbcdn.net&_nc_cat=101&oh=c74ef062e66a37ad4e9bc4c319775395&oe=5EAE6416 )
  3. Right click on the image and choose "Copy Image"
  4. Paste to other application such as mspaint.exe

Actual Results:
Paste menu is disabled.
Nothing is pasted.

Expected Results:
Paste menu should be enabled.
The image should be pasted.

Regression Window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=958f25e0cae235999026bf83e7af2a113c9a1605&tochange=3dc70a33491f26ffcd6c7bdf4e9d7a8b2e052e4e

Flags: needinfo?(kmaglione+bmo)

Confirmed, Setting fission.rebuild_frameloaders_on_remoteness_change to false fixes the issue.

Has Regression Range: --- → yes
Has STR: --- → yes
Component: General → DOM: Core & HTML
See Also: → 1603996, 1603472
Duplicate of this bug: 1603472

(In reply to Alice0775 White from comment #1)

Confirmed, Setting fission.rebuild_frameloaders_on_remoteness_change to false fixes the issue.

kmag, this bug is a regression from enabling frameloader rebuilding in bug 1583614.

Tentatively assigning to kmag. P1 because Relman has tagged this bug as a blocker for Firefox 73.

Assignee: nobody → kmaglione+bmo

It was being set to null before we tried to remove it, which left a dead
controller registered and consuming commands after a frameloader rebuild.

Duplicate of this bug: 1603996
Duplicate of this bug: 1605678
Severity: normal → critical
Flags: needinfo?(kmaglione+bmo)
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8f97448e08d6
Part 1 - Correctly unregister controller when destroying browser. r=NeilDeakin
https://hg.mozilla.org/integration/autoland/rev/fe255b87d1e5
Part 2 - Convert RemoteController.js to a JSM. r=NeilDeakin
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Please nominate this for Beta approval when you get a chance. Let's also get QA to verify ASAP.

Flags: qe-verify+
Flags: needinfo?(kmaglione+bmo)

Reproduced the initial issue using Beta build 73.0b1 (Build id: 20200106175743).
Verified - Fixed in latest Nightly build 74.0a1 (Build id: 20200108215606) using Windows 10.

Duplicate of this bug: 1608324

Comment on attachment 9116547 [details]
Bug 1604003: Part 1 - Correctly unregister controller when destroying browser. r=NeilDeakin

Beta/Release Uplift Approval Request

  • User impact if declined: This issue prevents certain actions (e.g., copying an image URL) from working in a tab after it has switched from one process to another (e.g., after navigating from the new tab page to an ordinary web page)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a relatively small change to make sure we unregister a stale object before we set it to null rather than trying to unregister it after.
  • String changes made/needed:
Flags: needinfo?(kmaglione+bmo)
Attachment #9116547 - Flags: approval-mozilla-beta?
Attachment #9116548 - Flags: approval-mozilla-beta?

Comment on attachment 9116547 [details]
Bug 1604003: Part 1 - Correctly unregister controller when destroying browser. r=NeilDeakin

Fixes a regression picking up a number of duplicate reports. Verified on Nightly. Approved for 73.0b4.

Attachment #9116547 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9116548 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - Fixed in latest Beta build 73.0b4 (Build id: 20200112220634) using Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1609000
Blocks: 1534172

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
Root Cause: ? → Coding: Logical Error
You need to log in before you can comment on or make changes to this bug.