Closed Bug 1604053 Opened 2 years ago Closed 2 years ago

Firefox vr. 71 error socket whatsapp Web

Categories

(Core :: Networking, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1601671

People

(Reporter: sidneiggoncalves, Unassigned)

Details

Attachments

(1 file)

428.44 KB, application/x-zip-compressed
Details
Attached file Mozila Evidencias.zip

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.79 Safari/537.36

Steps to reproduce:

Baixar o Mozila Firefox 71.0 Produção, configurar em suas configurações de proxy para utilizar o seguinte endereço de Proxy (pfsense 2.4) com Squid Proxy Server (0.4.44.8) configurado como Proxy transparente HTTP.
Abrir o navegador Mozila Firefox supracitado, e abrir a pagina do Whatsapp Web, o QRCode de acesso não é carregado e fica em loop infinito.

Actual results:

Ao utilizar a versão 71.0 do Mozila Firefox com utilizando Proxy (Pfsense 2.4) o navegador não consegue gerar corretamente o QRCode do Whatsapp Web, além de problemas para baixar e anexar arquivos no GMAIL.
Conforme logs o Mozila Firefox não consegue estabelecer conexão socket com o servidor wss:\web.whatsapp.com\us

Ao utilizar a versão 70 do mozila firefox este erro não ocorre.

Expected results:

Ao abrir a pagina do Whatsapp Web deveria abrir o QRCode normalmente conforme ocorre na versão 70 deste navegador.

Hi, did you report this to pfsense? Could you explain what makes you think that this is an issue in Firefox code?

Hi, Could you please write this bug in english?

Thanks in advance, Flor.

Flags: needinfo?(sidneiggoncalves)

(In reply to Andre Klapper from comment #1)

Hi, did you report this to pfsense? Could you explain what makes you think that this is an issue in Firefox code?

Hi, Andre Klapper,

There is no need to report this error to Pfsense (Netgate) as the error is in switching from Mozilla Firefox browser version from version 70 to version 71.
Pfsense (netgate) will report that the problem is Mozila

Flags: needinfo?(sidneiggoncalves)

(In reply to Florencia Di Ciocco from comment #2)

Hi, Could you please write this bug in english?

Thanks in advance, Flor.

OK,

I use Pfsense with Squid and have identified that when upgrading Mozilla Firefox browser to version 71 Whatsapp Web QRCode does not load properly.

Only going back to version 70 will work correctly.

Something has been implemented in version 71 that is not properly handling the connection using Proxy.

I mentioned PFsense because it's the firewall I use, but Squid is worldwide.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Networking
Product: Firefox → Core

Hello Reporter,
Did you use system proxy in Firefox and the system set HTTP proxy?
Looks like a known issue in bug 1601671 which is with a patch under review.

Flags: needinfo?(sidneiggoncalves)

(In reply to Junior [:junior] from comment #6)

Hello Reporter,
Did you use system proxy in Firefox and the system set HTTP proxy?
Looks like a known issue in bug 1601671 which is with a patch under review.

Hello Junior,

Apparently it's the same problem.

Flags: needinfo?(sidneiggoncalves)

Thanks for reporting this issue

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1601671

I really have a problem here. And it happens similarly in Firefox Send the files are not sent when a proxy (squid) is used. In version 70 it worked perfectly.

After I disabled proxy for Socks it worked

You need to log in before you can comment on or make changes to this bug.