Closed Bug 1604166 Opened 3 years ago Closed 3 years ago

No way to change `intl.charset.fallback.override` even though it still affects text encoding selection

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1602213

People

(Reporter: emk, Unassigned)

References

(Regression)

Details

(Keywords: regression)

https://phabricator.services.mozilla.com/D56362#1732406

It shouldn't actually matter anywhere if intl.charset.detector.ng.enabled is true. Once it's time to remove the intl.charset.detector.ng.enabled pref, all that code can go away as dead code.

I found a case intl.charset.fallback.override is still relevant even if intl.charset.detector.ng.enabled is true.

Steps to reproduce:

  1. Install the latest en-US localization of Nightly.
  2. Open http://rokuhara.ie-t.net/Changelog.txt.
  3. Make sure that text encoding Western is selected.
  4. Open about:config in a new tab.
  5. Change intl.charset.fallback.override value to Shift_JIS.
  6. Back to the previous tab that was opened in step 2.
  7. Reload the page.

Actual result:
A different text encoding (Shift_JIS, but don't tell from the text encoding menu) is selected.

Expected result:
The text encoding should not be changed.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1602213
Has Regression Range: --- → yes
Keywords: regression
You need to log in before you can comment on or make changes to this bug.