Closed Bug 1604336 Opened 7 months ago Closed 5 months ago

Form autofill popup gets dismissed automatically/too quickly

Categories

(Toolkit :: Form Autofill, defect, P1)

71 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- unaffected

People

(Reporter: yoasif, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

From https://www.reddit.com/r/firefox/comments/e9n86n/i_think_the_most_recent_update_may_have_messed/

The problem in question is this - On certain sites (not so much reddit actually), when I click such a field, the dropdown menu will show up for a second and disappear, or not show up at all... it's only after a minute or so (or more) that it stays, like it did before.

At first I thought this was a mouse sensitivity issue and it's thinking I was double clicking, but pretty sure that is not the case since on other sites it works fine, and I never touched any mouse settings between then and when I didn't have this problem.

mozregression points to Bug 1573836 but the user doesn't have Fission enabled.

Steps to reproduce:

So this doesn't happen on all sites, only some. But here's the steps I took for each test.

  1. Go to www.sporcle.com (trivia quiz site).
  2. Type something in the search bar, hit enter, then go back to the homepage.
  3. Click the search bar. That should bring down a menu of search history on that site (what you just searched).

What happens:

And here's where the bug is - The search history dropdown might show up for a second and disappear, or show up and disappear after a couple seconds, but basically not stay steady and keep disappearing until you click it again (if you can even get it to stay steady). That's the BAD symptom -

Expected result:

but if the search history dropdown stays steady no problem and doesn't flicker and dance around and keep running away, that's GOOD.

Has Regression Range: --- → yes
Keywords: regression
Regressed by: 1573836
Attached file about:support

I wonder if bug 1595875 fixed this in Fx72. Can you have the reporter test in Beta? They will have to save a new address in that new beta profile.

Flags: needinfo?(yoasif)
Priority: -- → P1

Matthew, would Nightly work for a test? Beta reuses release profiles and I don't want to break their release profile with beta, since that may be confusing.

Flags: needinfo?(yoasif) → needinfo?(MattN+bmo)

(In reply to Asif Youssuff from comment #3)

Matthew, would Nightly work for a test? Beta reuses release profiles and I don't want to break their release profile with beta, since that may be confusing.

Oh, I forgot about that. Yes, that's fine.

Flags: needinfo?(MattN+bmo)

Too late to fix in 71. NI Asif to confirm that this is fixed in 72+.

Flags: needinfo?(yoasif)

User says it continues to occur in Nightly.

Flags: needinfo?(yoasif)

User says the issue persisted in nightly as of a week ago. I assume that means it is still broken in 72 and 73.

Hi,
I was able to reproduce this bug on Windows 10 on Release 72.0.2 (64-bit) and Beta 73.0b9 (64-bit), but not on Nightly 71.0a1 (2019-10-18) (64-bit) which means that this bug has already been resolved and it will eventually work on future Firefox Release versions. Corresponding flag has been revised and status has been changed to 'Resolved-Works for me'.

Firefox Nightly is made by codes and fixes made by Mozilla developers, that are compiled into a common code repository (Mozilla-central) to create a pre-release version of Firefox for testing purposes. After the code on Nightly matures, it is merged into stabilization repositories (Beta, ESR and Dev Edition) where that code will be polished until reaching the final version of Firefox (Release).

I leave you the link with the Firefox Release Calendar (https://wiki.mozilla.org/Release_Management/Calendar). When Release reaches Beta's actual version (70) you will no longer encounter the problem.

I’ll mark this ticket as resolved since once the natural cycle is complete you won't have this bug; but feel free to reopen it if you experience this behaviour in the future once the migration to Release has been made.

Regards,
Jerónimo.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → WORKSFORME

I think I got needinfo'd by mistake…

Flags: needinfo?(MattN+bmo)
You need to log in before you can comment on or make changes to this bug.