Closed Bug 1604475 Opened 2 years ago Closed 2 years ago

Error while detaching the worker target front: Error: "wrongState"

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: Honza, Unassigned)

References

(Blocks 1 open bug)

Details

STR:

  1. Open DevTools, select the Debugger panel
  2. Open Browser Console
  3. Load http://firefox-devtools-waiting-sw.glitch.me/
  4. Click the Update button on the page
  5. Check out the Browser Console it shows the following error:
Error while detaching the worker target front: Error: "wrongState"
    onPacket resource://devtools/shared/protocol/Front.js:276
    DevTools RDP*request resource://devtools/shared/protocol/Front.js:214
    name resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:49
    detach resource://devtools/shared/fronts/targets/worker.js:93
    _destroyTarget resource://devtools/shared/fronts/targets/target-mixin.js:462
    destroy resource://devtools/shared/fronts/targets/target-mixin.js:423
    newListener resource://devtools/shared/event-emitter.js:154
    emit resource://devtools/shared/event-emitter.js:195
    emit resource://devtools/shared/event-emitter.js:276
    onPacket resource://devtools/shared/protocol/Front.js:252
    onPacket resource://devtools/shared/client/debugger-client.js:496
    send resource://devtools/shared/transport/local-transport.js:70
    makeInfallible resource://devtools/shared/ThreadSafeDevToolsUtils.js:111
    executeSoon resource://devtools/shared/DevToolsUtils.js:62
    send resource://devtools/shared/transport/local-transport.js:58
    send resource://devtools/server/debugger-server-connection.js:91
    receiveMessage resource://devtools/shared/transport/child-transport.js:66
    _addListener resource://devtools/shared/transport/child-transport.js:40
    ready resource://devtools/shared/transport/child-transport.js:57
    listener resource://devtools/server/connectors/content-process-connector.js:43
    connectToContentProcess resource://devtools/server/connectors/content-process-connector.js:32
    connectToContentProcess resource://devtools/server/connectors/content-process-connector.js:28
    _childProcessConnect resource://devtools/server/actors/descriptors/process.js:95
    getTarget resource://devtools/server/actors/descriptors/process.js:129
    handler resource://devtools/shared/protocol/Actor.js:154
    onPacket resource://devtools/server/debugger-server-connection.js:380
    send resource://devtools/shared/transport/local-transport.js:70
    makeInfallible resource://devtools/shared/ThreadSafeDevToolsUtils.js:111
    executeSoon resource://devtools/shared/DevToolsUtils.js:62
    send resource://devtools/shared/transport/local-transport.js:58
    send resource://devtools/shared/protocol/Front.js:198
    request resource://devtools/shared/protocol/Front.js:216
    name resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:49
    _targetFrontPromise resource://devtools/shared/fronts/descriptors/process.js:74
    getTarget resource://devtools/shared/fronts/descriptors/process.js:91
    listAllWorkerTargets resource://devtools/shared/fronts/root.js:224
    listWorkerTargets resource://devtools/client/debugger/src/client/firefox/targets.js:93
    updateTargets resource://devtools/client/debugger/src/client/firefox/targets.js:173
    fetchThreads resource://devtools/client/debugger/src/client/firefox/commands.js:454
    updateThreads resource://devtools/client/debugger/src/actions/threads.js:25
    thunk resource://devtools/client/debugger/src/actions/utils/middleware/thunk.js:29
    dispatch Redux
    connect resource://devtools/client/debugger/src/actions/navigation.js:62
    thunk resource://devtools/client/debugger/src/actions/utils/middleware/thunk.js:29
    bindActionCreator Redux
    onConnect resource://devtools/client/debugger/src/client/firefox.js:68
    onConnect resource://devtools/client/debugger/src/client/index.js:84
    bootstrap resource://devtools/client/debugger/src/main.js:28
    open resource://devtools/client/debugger/panel.js:45
    onLoad resource://devtools/client/framework/toolbox.js:2446
worker.js:95:15

I am also often seeing:

Error: "Protocol error (noSuchActor): No such actor for ID: server0.conn2.content-process18/workerTarget5"

Honza

@Brian, can you please look at this, thanks!

Honza

Flags: needinfo?(bhackett1024)

I've looked into this and think it is a benign warning. This message is generated because the worker's actor is detached from twice while it is closing, and the error thrown on the second time is just caught and logged. I would rather just ignore this, as I don't feel comfortable working on this or other target related bugs after the events of last month.

Flags: needinfo?(bhackett1024)

I am closing this since I can't reproduce the original error anymore.

The Error: "Protocol error (noSuchActor) is still there, but it's reported as bug 1622014

Honza

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.