mouse buttons dont work as hoped

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: iamfrank, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

I've noticed a lot of mice have back/forward buttons as mine do for traversing
through web pages.  I have one of these such mice, and being new to Mozilla from
IE I'm finding it really frustrating that they don't work in anything but IE.  

Reproducible: Always
Steps to Reproduce:
1.Push back button on mouse


Actual Results:  Nothing

Expected Results:  Gone to the previous page

Comment 1

17 years ago
I'm no expert, but I suspect that this depends on the mouse driver;
for example, I have a Logitech mouse, and have successfully been using
"internet back" for my fourth button.

It may be worthwhile looking for a newer driver for your mouse, in
case that fixes the issue, or poking around on the manufacturer's
website for any forums of people discussing the same problem.

At the very least, it would probably be helpful to post what
brand and model of mouse you're using, and what version of the drivers.
(Reporter)

Comment 2

17 years ago
Its a Microsoft intelliMouse Explorer with just the standard drivers that come
with Windows XP.  I know its just a rebadged Logitech, how do you think I could
get it to work?
(Reporter)

Comment 3

17 years ago
You need to install MS Intellimouse and set it to explicity mean that the
buttons are for back and forward.  IE must just assume...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
For tracking, should this be re-resolved as a dup of bug 30431?
 

Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.