Closed Bug 1604680 Opened 2 years ago Closed 1 year ago

Crash in [@ __memcpy_sse2_unaligned_erms | SkSpriteBlitter_Memcpy::blitRect]

Categories

(Core :: Graphics, defect, P2)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- wontfix
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: past, Assigned: edgar)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-90ca4175-cad7-4225-922b-b67940191217.

Top 10 frames of crashing thread:

0 libc-2.24.so __memcpy_sse2_unaligned_erms 
1 libxul.so SkSpriteBlitter_Memcpy::blitRect gfx/skia/skia/src/core/SkBlitter_Sprite.cpp:89
2 libxul.so SkScan::FillIRect gfx/skia/skia/src/core/SkScan.cpp
3 libxul.so SkScan::FillIRect gfx/skia/skia/src/core/SkScan.cpp:78
4 libxul.so SkDraw::drawBitmap const gfx/skia/skia/src/core/SkDraw.cpp:1123
5 libxul.so SkBitmapDevice::drawBitmap gfx/skia/skia/src/core/SkBitmapDevice.cpp:407
6 libxul.so SkBitmapDevice::drawBitmapRect gfx/skia/skia/src/core/SkBitmapDevice.cpp:508
7 libxul.so SkBaseDevice::drawImageRect gfx/skia/skia/src/core/SkDevice.cpp:156
8 libxul.so SkCanvas::onDrawImageRect gfx/skia/skia/src/core/SkCanvas.cpp:2341
9 libxul.so SkCanvas::drawImageRect gfx/skia/skia/src/core/SkCanvas.cpp:1786

This was reported by the Cypress.io team who are hitting it very frequently in a Docker container with 8 GB of memory.

(In reply to Panos Astithas (he/him) [:past] (please ni?) from comment #0)

This was reported by the Cypress.io team who are hitting it very frequently in a Docker container with 8 GB of memory.

So maybe a fallible allocation site we need to null check somewhere?

There are some more questions to ask, and we should get an answer to those soon. I asked the person via email.

So what we will have to know:

  1. Which steps / tools have been used to take the screenshot? What is the URL of the page, and how large is the area to capture?
  2. Does the same problem still exist in Firefox Nightly?
  3. How much memory is reserved for /dev/shm? There is a known problem if it is too low (bug 1245239), and since bug 1595395 (but that's Firefox 72) we transfer the image via SHM and not as IPC payload anymore (the latter caused crashes for huge screenshots).
Priority: -- → P2

This might be the final effect from what we can see on bug 1608501.

Duplicate of this bug: 1626042

Peter how does your test look like? Also see comment 2 for the questions 2) and 3).

Flags: needinfo?(petersan)
See Also: → 1631680

Very low number of crashes. Lets see in some weeks if the fix on bug 1608501 actually fixed that.

Flags: needinfo?(petersan)

There are no more reported crashes for Nightly and beta since the 80 train. So lets close as fixed by bug 1608501.

Assignee: nobody → echen
Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1608501
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.