Closed Bug 1604737 Opened 8 months ago Closed 7 months ago

Stop running fission test variants on ash

Categories

(Testing :: Performance, task, P3)

Other Branch
task

Tracking

(Fission Milestone:M6, firefox74 fixed)

RESOLVED FIXED
mozilla74
Fission Milestone M6
Tracking Status
firefox74 --- fixed

People

(Reporter: marauder, Assigned: marauder)

References

Details

Attachments

(1 file, 1 obsolete file)

I opened this follow-up bug in case we want to stop running fission test variants on ash.

More details:
https://phabricator.services.mozilla.com/D56411#1739680

:ahal : "If the fission team wants certain tasks to stop running on ash then we'll need to change the fission infrastructure a bit. If this is the case we should handle it in a follow-up bug. I could potentially take a look at fixing it."

See Also: → 1594631

Marian, the Fission team is done using ash, so you can stop running Fission test variants on ash.

Fission Milestone: --- → M6
Flags: needinfo?(marian.raiciof)
Summary: [IF-NEEDED] Stop running fission test variants on ash → Stop running fission test variants on ash

Thanks Chris, i created the patch above.

Andrew, can you do the changes for fission infrastructure, as stated in https://bugzilla.mozilla.org/show_bug.cgi?id=1604737#c0 ?

Thanks!

Flags: needinfo?(marian.raiciof) → needinfo?(ahal)
Assignee: nobody → marian.raiciof
Status: NEW → ASSIGNED

Sure!

Flags: needinfo?(ahal)
Attachment #9117883 - Attachment is obsolete: true
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/859aa752f8e7
[ci] Stop running all fission tasks on Ash, r=jmaher
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Marian, does the improvement below makes sense to be caused by this bug? I retriggered some jobs here and there. My impression is that there's a hidden dual mode here.
== Change summary for alert #24613 (as of Tue, 07 Jan 2020 08:34:54 GMT) ==

Improvements:

17% raptor-tp6-bing-firefox-cold loadtime macosx1014-64-shippable opt 576.42 -> 477.92
15% raptor-tp6-bing-firefox-cold macosx1014-64-shippable opt 413.31 -> 349.48
14% raptor-tp6-bing-firefox-cold fcp macosx1014-64-shippable opt 397.92 -> 342.92
9% raptor-tp6-paypal-firefox-cold loadtime macosx1014-64-shippable opt 1,139.83 -> 1,031.75

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=24613

Flags: needinfo?(marian.raiciof)

Looks like the improvement is actually a dual modality. it's weird that this patch caused dual modality, though. I will look further into it.

Perhaps the perf regression bot is comparing the previous Fission benchmark results with the current non-Fission results on Ash?

I don't know.
Andrew what do you think ?
Thanks!

Flags: needinfo?(ahal)

If it was running on ash we can ignore it and simply stop monitoring that branch. But it looks like the link :alexandrui posted is for autoland. Alexandru, are you sure the dual modality you are seeing was caused by this patch? I'd expect it to have 0 impact on autoland/central.

The only thing that I could conceivably think of is that maybe the workers running the raptor tasks have different artifacts/caches lying around on their file systems. But if that is causing perf differences then we have a problem in our harnesses.

Flags: needinfo?(ahal)
Flags: needinfo?(aionescu)

Andrew, the dual modality stopped around Jan 9. Did some triggers to find out what's the responsible commit for this.

Flags: needinfo?(aionescu)
You need to log in before you can comment on or make changes to this bug.