'Replace and Find' button gives double 'not found' dialog

RESOLVED FIXED in mozilla1.2alpha

Status

MailNews Core
Composition
--
minor
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Ivo Jansch, Assigned: Akkana Peck)

Tracking

Trunk
mozilla1.2alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
 
(Reporter)

Comment 1

16 years ago
In the 'Find and Replace' dialog, there's a button 'Replace and Find'.

If I enter a text that cannot be found, and I press 'Replace and Find', I get 2
popups saying that the text cannot be found.
Severity: normal → minor
Summary: Replace and Find' → 'Replace and Find' button gives double 'not found' dialog

Comment 2

16 years ago
-->akkana
Assignee: ducarroz → akkana

Updated

16 years ago
QA Contact: esther → sujay

Comment 3

16 years ago
The reason is that if current selection doesn't match the search str, 
onFindNext() will be called twice. This is wrong.

Comment 4

16 years ago
maybe you can fix it before we go gym?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Created attachment 93678 [details] [diff] [review]
don't call onFindNext() in onReplace()

I think we don't need to call onFindNext() in onReplace(). Click Replace button
should do nothing if current selection doesn't match the select str. User
should use Find button to do the find.
Akkana, what do you think of it?
(Assignee)

Comment 6

16 years ago
Yes, quite right.  r=akkana.  Thanks, Harry!  Kin, can you sr this?  It's a
one-line patch.
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Attachment #93678 - Flags: review+
(Assignee)

Comment 7

16 years ago
Argh -- this never got a super-review!  Simon, can you please sr this one-line
patch?
Target Milestone: --- → mozilla1.2alpha

Comment 8

16 years ago
Comment on attachment 93678 [details] [diff] [review]
don't call onFindNext() in onReplace()

sr=sfraser
Attachment #93678 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.