Closed Bug 1604901 Opened 2 years ago Closed 2 years ago

Mozregression cannot launch desktop Firefox on Windows

Categories

(Testing :: mozregression, defect)

Version 3
Desktop
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: JanH, Assigned: ahal)

References

Details

Attachments

(2 files)

Mozregression seems to be using a version of mozprocess that suffers from bug 1585702, leading to it being unable to launch Firefox on Windows.

Looks like the latest version of mozprocess available on pypi does not have this:

https://pypi.org/project/mozprocess/

Andrew and/or gbrown, could you please version bump mozprocess and upload it to pypi with this fix? Once that's done I can make a new release of mozregression which depends on it.

Flags: needinfo?(gbrown)
Flags: needinfo?(ahal)

Sure, I'll do it and attach to this bug.

Flags: needinfo?(gbrown)
Flags: needinfo?(ahal)
Keywords: leave-open

Perusing the changelog, the differences since last version bump are mostly
centered around ironing Python 3 issues. Nothing that should be backwards
incompatible, but larger changes than a dot release might warrant. So bumping
the minor version.

Assignee: nobody → ahal
Status: NEW → ASSIGNED
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e15763c3316
[mozprocess] Version bump to 1.1.0, r=gbrown

Thanks Andrew, please let me know when you've uploaded it to pypi as well

Sure thing, I'll wait for it to merge first.

Flags: needinfo?(ahal)

Ok, mozprocess 1.1.0 released:
https://pypi.org/project/mozprocess/1.1.0/

Flags: needinfo?(ahal)
Commit merged into master by GitHub
Authored by William Lachance (wlach)

The priority flag is not set for this bug.
:wlach, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(wlachance)

gui 0.9.44 released with the new mozprocess:

https://github.com/mozilla/mozregression/releases/tag/gui-0.9.44

The command-line version no longer pins deps, so no need for a new version there.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(wlachance)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.