absolute path to Mozilla profile directory

VERIFIED DUPLICATE of bug 157662

Status

--
major
VERIFIED DUPLICATE of bug 157662
17 years ago
14 years ago

People

(Reporter: glist, Assigned: Matti)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
absolute path to Mozilla profile directory

Platform: Windows NT / Windows 2000, roaming profiles (samba pdc)
Mozilla 1.0

In Windows NT user profile is stored under c:\winnt\profiles\user, in Windows
2000 under "C:\Dokumente und Einstellungen\user" (german version).

Mozilla 1.0 seems to store absolute pathnames to its profile-directories (in 
registry.dat?).

When I start mozilla the first time on win nt, the mozilla-profile directory is
created. When I start mozilla on a win2k-workstation  (after roaming has taken
place) I get error messages like "profile not found".

This behaviour doesn't let people use mozilla in a roaming environement. Even
on the same platform, oems sometimes have c:\winnt.0 or c:\windows as %windir.

IMO, the solution would be to store mozilla's profile path's relative to
%userprofile.

--
 Georg
(Assignee)

Comment 1

17 years ago
dupe f bug 157662

Mail will still not work because there are also absolute Paths in prefs.js for mail.
yes, we gave a bug about that - search yourself


*** This bug has been marked as a duplicate of 157662 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.