Closed Bug 1605152 Opened 2 years ago Closed 2 years ago

Intermittent devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | A promise chain failed to handle a rejection: this.transport is null - stack: send@resource://devtools/server/debugger-server-connection.js:91:5

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ochameau)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: dluca [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=281929556&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/fBkga0sZRWa4IfogQfXpug/runs/0/artifacts/public/logs/live_backing.log


INFO - TEST-START | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js
[task 2019-12-19T15:56:14.739Z] 15:56:14     INFO - TEST-INFO | started process screenshot
[task 2019-12-19T15:56:14.802Z] 15:56:14     INFO - TEST-INFO | screenshot: exit 0
[task 2019-12-19T15:56:14.802Z] 15:56:14     INFO - Buffered messages logged at 15:56:13
[task 2019-12-19T15:56:14.802Z] 15:56:14     INFO - Entering test bound 
[task 2019-12-19T15:56:14.803Z] 15:56:14     INFO - Console message: [JavaScript Error: "TypeError: this.transport is null" {file: "resource://devtools/server/debugger-server-connection.js" line: 91}]
[task 2019-12-19T15:56:14.803Z] 15:56:14     INFO - Console message: [JavaScript Warning: "The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page."]
[task 2019-12-19T15:56:14.804Z] 15:56:14     INFO - Adding a new tab with URL: data:text/html,<script>console.log("hello from content")</script>
[task 2019-12-19T15:56:14.804Z] 15:56:14     INFO - Buffered messages logged at 15:56:14
[task 2019-12-19T15:56:14.806Z] 15:56:14     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<script>console.log("hello from content")</script>" line: 0}]
[task 2019-12-19T15:56:14.806Z] 15:56:14     INFO - Tab added and finished loading
[task 2019-12-19T15:56:14.806Z] 15:56:14     INFO - Opening the toolbox
[task 2019-12-19T15:56:14.807Z] 15:56:14     INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-12-19T15:56:14.808Z] 15:56:14     INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2019-12-19T15:56:14.808Z] 15:56:14     INFO - Toolbox opened and focused
[task 2019-12-19T15:56:14.808Z] 15:56:14     INFO - Wait for expected message are shown on browser console
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - Console message: [JavaScript Error: "Cu.reportError" {file: "debugger eval code" line: 1}]
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - @debugger eval code:1:4
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - getEvalResult@resource://devtools/server/actors/webconsole/eval-with-debugger.js:172:28
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - exports.evalWithDebugger@resource://devtools/server/actors/webconsole/eval-with-debugger.js:139:31
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - evaluateJS@resource://devtools/server/actors/webconsole.js:1156:38
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - evaluateJSAsync/<@resource://devtools/server/actors/webconsole.js:1053:29
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:62:21
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - evaluateJSAsync@resource://devtools/server/actors/webconsole.js:1050:19
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - handler@resource://devtools/shared/protocol/Actor.js:154:37
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - onPacket@resource://devtools/server/debugger-server-connection.js:380:58
[task 2019-12-19T15:56:14.809Z] 15:56:14     INFO - send/<@resource://devtools/shared/transport/local-transport.js:70:25
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:111:22
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:62:21
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - send@resource://devtools/shared/transport/local-transport.js:58:21
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - send@resource://devtools/shared/protocol/Front.js:198:30
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - request@resource://devtools/shared/protocol/Front.js:216:10
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:49:19
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - evaluateJSAsync@resource://devtools/shared/fronts/webconsole.js:206:38
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - evaluateJSAsync@resource://devtools/client/webconsole/commands.js:38:18
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - evaluateExpression/<@resource://devtools/client/webconsole/actions/input.js:94:8
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - async*thunkWithOptions/</<@resource://devtools/client/shared/redux/middleware/thunk-with-options.js:16:9
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - ignore/</<@resource://devtools/client/shared/redux/middleware/ignore.js:28:12
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - dispatchEvaluateExpression@resource://devtools/client/webconsole/webconsole-wrapper.js:335:11
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - execute@chrome://mochitests/content/browser/devtools/client/webconsole/test/browser/head.js:238:25
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - @chrome://mochitests/content/browser/devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js:26:10
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1062:34
[task 2019-12-19T15:56:14.810Z] 15:56:14     INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1097:11
[task 2019-12-19T15:56:14.811Z] 15:56:14     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:925:14
[task 2019-12-19T15:56:14.811Z] 15:56:14     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:808:67
[task 2019-12-19T15:56:14.811Z] 15:56:14     INFO - 
[task 2019-12-19T15:56:14.811Z] 15:56:14     INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | Expected messages are displayed in the browser console - 
[task 2019-12-19T15:56:14.811Z] 15:56:14     INFO - Uncheck the Show content messages checkbox
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - Check the expected messages are still visiable in the browser console
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | "Cu.reportError" should be still visible - 
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - Buffered messages finished
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | A promise chain failed to handle a rejection: this.transport is null - stack: send@resource://devtools/server/debugger-server-connection.js:91:5
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - writeError@resource://devtools/shared/protocol/Actor.js:98:15
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - generateRequestHandlers/</handler/</<@resource://devtools/shared/protocol/Actor.js:187:30
[task 2019-12-19T15:56:14.812Z] 15:56:14     INFO - promise callback*generateRequestHandlers/</handler/<@resource://devtools/shared/protocol/Actor.js:187:14
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - _queueResponse@resource://devtools/shared/protocol/Actor.js:107:28
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - handler@resource://devtools/shared/protocol/Actor.js:183:14
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - onPacket@resource://devtools/server/debugger-server-connection.js:380:58
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - send/<@resource://devtools/shared/transport/local-transport.js:70:25
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:111:22
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:62:21
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - send@resource://devtools/shared/transport/local-transport.js:58:21
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - send@resource://devtools/shared/protocol/Front.js:198:30
[task 2019-12-19T15:56:14.813Z] 15:56:14     INFO - request@resource://devtools/shared/protocol/Front.js:216:10
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:49:19
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - getTarget/this._targetFrontPromise<@resource://devtools/shared/fronts/descriptors/process.js:74:40
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - getTarget@resource://devtools/shared/fronts/descriptors/process.js:91:7
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - _processListChanged@resource://devtools/shared/resources/target-list.js:51:41
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - Async*emit@resource://devtools/shared/event-emitter.js:195:24
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - emit@resource://devtools/shared/event-emitter.js:276:18
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - onPacket@resource://devtools/shared/protocol/Front.js:252:13
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - onPacket@resource://devtools/shared/client/debugger-client.js:496:13
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - send/<@resource://devtools/shared/transport/local-transport.js:70:25
[task 2019-12-19T15:56:14.814Z] 15:56:14     INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:111:22
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:62:21
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - send@resource://devtools/shared/transport/local-transport.js:58:21
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - send@resource://devtools/server/debugger-server-connection.js:91:20
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - onProcessListChanged@resource://devtools/server/actors/root.js:562:15
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - observe@resource://devtools/server/actors/process.js:73:12
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - Rejection date: Thu Dec 19 2019 15:56:13 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - Stack trace:
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1093
[task 2019-12-19T15:56:14.815Z] 15:56:14     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
[task 2019-12-19T15:56:14.816Z] 15:56:14     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:925
[task 2019-12-19T15:56:14.816Z] 15:56:14     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:808
[task 2019-12-19T15:56:14.816Z] 15:56:14     INFO - Leaving test bound 
[task 2019-12-19T15:56:15.003Z] 15:56:15     INFO - Removing tab.
[task 2019-12-19T15:56:15.003Z] 15:56:15     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-12-19T15:56:15.018Z] 15:56:15     INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-12-19T15:56:15.018Z] 15:56:15     INFO - GECKO(3892) | console.warn: "IGNORED REDUX ACTION:" ({type:"AUTOCOMPLETE_CLEAR"})
[task 2019-12-19T15:56:15.021Z] 15:56:15     INFO - Tab removed and finished closing
[task 2019-12-19T15:56:15.056Z] 15:56:15     INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | The main process DebuggerServer has no pending connection when the test ends - 
[task 2019-12-19T15:56:15.111Z] 15:56:15     INFO - GECKO(3892) | MEMORY STAT | vsize 849MB | vsizeMaxContiguous 333MB | residentFast 313MB | heapAllocated 150MB
[task 2019-12-19T15:56:15.111Z] 15:56:15     INFO - TEST-OK | devtools/client/webconsole/test/browser/browser_console_chrome_context_message.js | took 1631ms
Regressed by: 1588050
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED

I'll mention this failure in bug 1605036 as both tests are failing with the same error.
In the meantime, I'll disable the Multiprocess Browser Toolbox pref which makes this test to fail.

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2ee844c18ad
Disable the Multiprocess toolbox for browser_console.js because of intermittent failures. r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
You need to log in before you can comment on or make changes to this bug.