Closed Bug 1605166 Opened 2 years ago Closed 2 years ago

Selecting non paused thread should switch context and update selector

Categories

(DevTools :: Debugger, enhancement, P1)

enhancement

Tracking

(Fission Milestone:M6, firefox75 fixed)

RESOLVED FIXED
Firefox 75
Fission Milestone M6
Tracking Status
firefox75 --- fixed

People

(Reporter: Honza, Assigned: jlast)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-m2-mvp )

Attachments

(1 file)

When the user selects non-paused thread in the Threads panel the execution context should switch to it and the Context Selector should be updated.

This allows the user to pause (on next execution) in selected thread (F8).

This is related to bug 1579102

Honza

Priority: P3 → P2

Tracking dt-fission-m2-mvp bugs for Fission Nightly (M6)

Fission Milestone: --- → M6
Duplicate of this bug: 1605165
Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4f17c4fa841b
Selecting non paused thread should switch context and update selector. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
You need to log in before you can comment on or make changes to this bug.