Broken authentication when accessing apache site with sspi_auth_module

VERIFIED DUPLICATE of bug 23679

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 23679
16 years ago
16 years ago

People

(Reporter: Jeremy Van Veelen, Assigned: Matti)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla doesn't even attempt to give authentication (eg. Get error 401 without
an auth pop-up window) when accessing an Apache 2.0.39 website that uses
sspi_auth_module (authenticates to a NT domain).

I verified that it works on Internet Explorer 6.0 just fine.

Could it be a Apache issue or mozilla issue?

Email me if you would like a login/password to experiment with.
(Assignee)

Comment 1

16 years ago
Do you mean NTLM auth ?
I can't get a DNS error for pages.drexel.edu
(Reporter)

Comment 2

16 years ago
Yes, I believe it uses NTLM auth.  See
http://www.syneapps.com/software/mod_auth_sspi/ for the module description.  Of
course that page points out that it works with IE 3+ and doesn't even mention
Netscape/Mozilla.

DNS error? I get a 401 Authorization Required error.  (And I also can't resolve
the ip of pages.drexel.edu, which may seem irrelevant).
(Assignee)

Comment 3

16 years ago
yes, its NTLM Auth.


*** This bug has been marked as a duplicate of 23679 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
VERIFIED/DUPE
Component: Browser-General → Networking
QA Contact: asa → benc

Comment 5

16 years ago
argh.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.