Closed Bug 1605544 Opened 1 year ago Closed 1 year ago

Intermittent toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | monitorConsole | messages left expected at least 1 got 0

Categories

(WebExtensions :: General, defect, P2)

defect

Tracking

(firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: zombie)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=282214448&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/PDBCWUoqRa-auGKxKalfqw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | undefined assertion name
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - Buffered messages finished
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | monitorConsole | messages left expected at least 1 got 0
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - finished@toolkit/components/extensions/test/mochitest/head.js:106:7
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - asyncexpectErrors@toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html:315:26
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - async
test_sub_subframe_conduit_verified_env@toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html:324:11
[task 2019-12-21T03:08:43.606Z] 03:08:43 INFO - asyncnextTick/<@SimpleTest/SimpleTest.js:1800:34
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - async
nextTick@SimpleTest/SimpleTest.js:1816:11
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:689:43
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - add_task@SimpleTest/SimpleTest.js:1760:17
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - @toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html:17:9
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - Conduit creation logged correct exception.
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - Try spoofing from the web process.
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - GECKO(5220) | [Child 8384, Main Thread] WARNING: NS_ENSURE_SUCCESS_VOID(rv) failed with result 0x80070057: file z:/build/build/src/toolkit/components/antitracking/AntiTrackingCommon.cpp, line 2036
[task 2019-12-21T03:08:43.607Z] 03:08:43 INFO - GECKO(5220) | [Parent 7312, Main Thread] WARNING: we only accept nsIURI interface type, patch welcome: file z:/build/build/src/dom/ipc/PropertyBagUtils.cpp, line 112
[task 2019-12-21T03:08:43.608Z] 03:08:43 INFO - GECKO(5220) | [Child 8384, Main Thread] WARNING: Trying to request nsIHttpChannel from DocumentChannelChild, this is likely broken: file z:/build/build/src/netwerk/ipc/DocumentChannelChild.cpp, line 63
[task 2019-12-21T03:08:43.669Z] 03:08:43 INFO - GECKO(5220) | [Child 8384, Main Thread] WARNING: Trying to request nsIHttpChannel from DocumentChannelChild, this is likely broken: file z:/build/build/src/netwerk/ipc/DocumentChannelChild.cpp, line 63

Whiteboard: [retriggered]

Jim, could you please redirect this to someone who can take a look? It already has 85 failure in 7 days since it was filed: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-12-20&endday=2019-12-27&tree=trunk&bug=1605544
and it will soon reach the disable recommended tag at this rate. It fails mostly on debug builds windows10-64, macosx1014-64 and linux64.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=282788416&repo=mozilla-central&lineNumber=6539

Flags: needinfo?(jmathies)
Assignee: nobody → tomica
Flags: needinfo?(tomica)
Flags: needinfo?(jmathies)
Priority: P5 → P2
Attachment #9117992 - Attachment description: Bug 1605544 - Fix inermittent test_sub_subframe_conduit_verified_env console check → Bug 1605544 - Fix intermittent test_sub_subframe_conduit_verified_env console check
Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ce2006dd193
Fix intermittent test_sub_subframe_conduit_verified_env console check r=rpl
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.