Closed Bug 1605576 Opened 8 months ago Closed 7 months ago

Permafailing devtools/client/webconsole/test/browser/browser_webconsole_stubs_page_error.js | "ReferenceError: asdf is not defined" when Gecko 73 merges to Beta on 2020-01-06

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(firefox-esr68 unaffected, firefox71 unaffected, firefox72 unaffected, firefox73+ fixed, firefox74 verified)

VERIFIED FIXED
Firefox 74
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 + fixed
firefox74 --- verified

People

(Reporter: nataliaCs, Assigned: Honza)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:
Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=a9116bffd43a99e4178fc73cc42135f703f07ac3&searchStr=devtools&selectedJob=282260140

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=282260140&repo=try&lineNumber=5475

[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @http://example.com/browser/devtools/client/webconsole/test/browser/test-console-api.html:1:7
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @resource://testing-common/content-task.js line 110 > eval:6:29
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @resource://testing-common/content-task.js:111:29
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO -
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - Console message: [JavaScript Error: "uncaught exception: "]
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @http://example.com/browser/devtools/client/webconsole/test/browser/test-console-api.html:1:1
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @resource://testing-common/content-task.js line 110 > eval:6:29
[task 2019-12-21T13:44:26.372Z] 13:44:26 INFO - @resource://testing-common/content-task.js:111:29
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO -
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - Buffered messages finished
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_stubs_page_error.js | "ReferenceError: asdf is not defined" packet has expected value - Got {
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - "pageError": {
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - "errorMessage": "ReferenceError: asdf is not defined",
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - "errorMessageName": "JSMSG_NOT_DEFINED",
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - "exceptionDocURL": "https://developer.mozilla.org/docs/Web/JavaScript/Reference/Errors/Not_defined?utm_source=mozilla&utm_medium=firefox-console-errors&utm_campaign=default",
[task 2019-12-21T13:44:26.373Z] 13:44:26 INFO - "sourceName": "http://example.com/browser/devtools/client/webconsole/test/browser/test-console-api.html",
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "sourceId": "server0.conn0.child1/source22",
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "lineText": "",
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "lineNumber": 3,
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "columnNumber": 5,
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "category": "content javascript",
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "innerWindowID": 8589934593,
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "timeStamp": 1573832650066,
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "warning": false,
[task 2019-12-21T13:44:26.374Z] 13:44:26 INFO - "error": false,
[task 2019-12-21T13:44:26.375Z] 13:44:26 INFO - "exception": true,

:nchevobbe could this be a regression from Bug 1530843 ?

Flags: needinfo?(nchevobbe)

This fails because javascript.options.asyncstack is only set to true in Nightly and Developer Edition: https://searchfox.org/mozilla-central/rev/8d04c3f5332d470eeae5aa3dc0ed132359a339c1/modules/libpref/init/all.js#1121

The expectations get autogenerated by browser_webconsole_stubs_page_error.js and stub-generator-helpers.js

Panos, please check if a developer will be able to fix this before January 6th. Developer and reviewer of regressing bug 1530843 are on PTO. Thank you in advance.

Flags: needinfo?(past)
Regressed by: 1530843

We'll take care of this when we're back next week.

Flags: needinfo?(past)

Honza, could you please find an owner for this?

Flags: needinfo?(odvarko)
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)
Priority: -- → P2

devtools/client/webconsole/test/browser/browser_webconsole_worker_error.js supposedly also needs the pref set: https://treeherder.mozilla.org/#/jobs?repo=try&revision=bd42b4b1ae1a79fe04ca091684a440c2ba6a34f6&selectedJob=283354045

Flags: needinfo?(odvarko)
Attachment #9118506 - Attachment description: Bug 1605576 - Proper pref setup in browser_webconsole_stubs_page_error.js → Bug 1605576 - Set javascript.options.asyncstack in browser_webconsole_stubs_page_error.js and browser_webconsole_worker_error.js
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/c053a4615ff7
Set javascript.options.asyncstack in browser_webconsole_stubs_page_error.js and browser_webconsole_worker_error.js r=nchevobbe
Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Flags: needinfo?(odvarko)
You need to log in before you can comment on or make changes to this bug.