Closed Bug 1605613 Opened 7 months ago Closed 7 months ago

Quick Filter search "No Results" text is chopped off on bottom by 1 pixel

Categories

(Thunderbird :: Search, defect)

defect
Not set
minor

Tracking

(thunderbird_esr68 fixed, thunderbird72 fixed, thunderbird73 fixed)

RESOLVED FIXED
Thunderbird 73.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird72 --- fixed
thunderbird73 --- fixed

People

(Reporter: webmaster2, Assigned: Paenglab)

References

Details

Attachments

(3 files)

Attached image no_results_1.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Search a folder using the filter; search for a anything that will not be found in order to produce the "No Results" message.

Actual results:

The message "No Results" has bottom 1 pixel row chopped off.

Attached image Enlargement

Tested using Tbird version 68.3.1 on Mac.

I'm seeing the same in Thunderbird 68.3.1 on Ubuntu 18.04.3 LTS and Windows 10.

Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → x86_64
Summary: Filter search "No Results" text is chopped off on bottom by 1 pixel → Quick Filter search "No Results" text is chopped off on bottom by 1 pixel
Duplicate of this bug: 1605638

The text baseline was directly on the bottom of the image. Made the image a bit taller to show the text elements below the baseline (g, j, y) too. The image was scaled when showing. I made it now unscaled to not get this huge font when a minimal font height is set.

Assignee: nobody → richard.marti
Attachment #9117478 - Flags: review?(mkmelin+mozilla)
Attachment #9117478 - Flags: approval-comm-esr68?
Attachment #9117478 - Flags: approval-comm-beta?
Severity: normal → minor
Comment on attachment 9117478 [details] [diff] [review]
1605613-search-not-found-increase.patch

Review of attachment 9117478 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thx! r=mkmelin
Attachment #9117478 - Flags: review?(mkmelin+mozilla)
Attachment #9117478 - Flags: review+
Attachment #9117478 - Flags: approval-comm-beta?
Attachment #9117478 - Flags: approval-comm-beta+
Status: NEW → ASSIGNED
Hardware: x86_64 → All
Target Milestone: --- → Thunderbird 73.0

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/e108db02cb6d
Increase the search-not-found.svg height to give the text some space below the baseline. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: Thunderbird 72.0 → Thunderbird 73.0
Attachment #9117478 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.