Closed Bug 1605667 Opened 1 year ago Closed 1 year ago

[wpt-sync] Sync PR 20905 - [web-animations] Fix test in setting-the-playbackrate-of-an-animation.html

Categories

(Core :: DOM: Animation, task, P4)

task

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 20905 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/20905
Details from upstream follow.

Brian Birtles <birtles@gmail.com> wrote:

[web-animations] Fix test in setting-the-playbackrate-of-an-animation.html

This test assumes that currentTime will not change after waiting for
ready but the spec does not require that so this patch inverts these two
lines.

Component: web-platform-tests → DOM: Animation
Product: Testing → Core

CI Results

Ran 13 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 1 tests and 8 subtests

Status Summary

Firefox

OK : 1
PASS: 8

Chrome

OK : 1
PASS: 8

Safari

OK : 1
PASS: 8

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf1b4540c640
[wpt PR 20905] - [web-animations] Fix test in setting-the-playbackrate-of-an-animation.html, a=testonly
https://hg.mozilla.org/integration/autoland/rev/06ad1ae19e96
[wpt PR 20905] - Update wpt metadata, a=testonly
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Duplicate of this bug: 1603538
You need to log in before you can comment on or make changes to this bug.