Closed Bug 1605855 Opened 2 years ago Closed 2 years ago

window_composition_text_querycontent.xhtml is not high DPI aware

Categories

(Core :: Widget, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

Details

(Keywords: inputmethod)

Attachments

(1 file)

If you run test_composition_text_querycontent.xhtml on your environment, and if your main display's scale is higher than 100% (i.e., window.devicePixelRatio is over 1.0), you may see some failures.

The failures are caused by synthesizeQuery* returns device pixels, but some of the failures calculating/comparing with CSS pixels, some other of them caused just rounding error. We should make the tests high DPI aware since high DPI environment is not so special in these days.

The failures which you see running the tests on high DPI display are caused by
synthesizeQuery* returns device pixels, but some of the failures
calculating/comparing with CSS pixels, or the other of them caused just
rounding error. This patch makes they refer window.devicePixelRatio and/or
use isfuzzy to compare.

The patched tests pass on 100%, 125%, 150%, 175%, 200% and 225% on Win10-ja.

Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/7a8425c45bc2
Make `window_composition_text_querycontent.xhtml` high DPI aware r=m_kato
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.