Closed Bug 1605906 Opened 2 months ago Closed 2 months ago

[Wayland][CompositorOGL] Toggling titlebar caused crash

Categories

(Core :: Graphics: Layers, defect)

Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR

  • [1] Forced to enable CompositorOGL with the following prefs
    • gfx.webrender.force-disabled=true
    • layers.acceleration.force-enabled=true
  • [2] Restart Firefox
  • [3] Go into Customize and toggle the titlebar.

Actual result
[3] caused a crash
Tested on Ubuntu 18.04

Summary: [Wayland][WebRender] Toggling titlebar caused crash → [Wayland][CompositorOGL] Toggling titlebar caused crash
Blocks: wayland
Regressed by: 1597861
Assignee: nobody → sotaro.ikeda.g
Attached file callstack of crash

The crash was almost same to Bug 1605893.

See Also: → 1605893
Duplicate of this bug: 1605893
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8748c266e9a
Add Pause/Resume handling to CompositorOGL for Wayland r=aosmond
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.