Closed Bug 1605940 Opened 7 months ago Closed 7 months ago

Perma beta browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Test timed out - when Gecko 73 merges to Beta on 2020-01-06

Categories

(Firefox :: Address Bar, defect)

73 Branch
defect
Not set
normal
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 74
Iteration:
73.2 - Dec 16 - Jan 5
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 + fixed
firefox74 --- verified

People

(Reporter: stefan_hindli, Assigned: harry)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=282599613&repo=try&lineNumber=3602

task 2019-12-25T14:19:51.993Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | extra[selIndex] must match in event urlbar#engagement#click. - "0" matches "0" -
[task 2019-12-25T14:19:51.993Z] 14:19:51 INFO - Running test at index 17
[task 2019-12-25T14:19:51.993Z] 14:19:51 INFO - Open the panel with dropmarker, type something, Enter.
[task 2019-12-25T14:19:51.993Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | parent must be in snapshot. Has [parent]. - true == true -
[task 2019-12-25T14:19:51.994Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | After filtering we must have the expected number of events. - 1 == 1 -
[task 2019-12-25T14:19:51.996Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | category in event urlbar#engagement#enter must match. - "urlbar" matches "urlbar" -
[task 2019-12-25T14:19:51.996Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | method in event urlbar#engagement#enter must match. - "engagement" matches "engagement" -
[task 2019-12-25T14:19:51.996Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | object in event urlbar#engagement#enter must match. - "enter" matches "enter" -
[task 2019-12-25T14:19:51.996Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | value in event urlbar#engagement#enter must match. - "topsites" matches "topsites" -
[task 2019-12-25T14:19:51.997Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Actual event urlbar#engagement#enter expected to have extra. - true == true -
[task 2019-12-25T14:19:51.997Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Expected key elapsed must be in actual extra. Actual keys: [elapsed,numChars,selIndex,selType]. - true == true -
[task 2019-12-25T14:19:51.997Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | extra[elapsed] must match in event urlbar#engagement#enter. - "242" matches "val => parseInt(val) > 0" -
[task 2019-12-25T14:19:51.999Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Expected key numChars must be in actual extra. Actual keys: [elapsed,numChars,selIndex,selType]. - true == true -
[task 2019-12-25T14:19:51.999Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | extra[numChars] must match in event urlbar#engagement#enter. - "1" matches "1" -
[task 2019-12-25T14:19:51.999Z] 14:19:51 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Expected key selType must be in actual extra. Actual keys: [elapsed,numChars,selIndex,selType]. - true == true -
[task 2019-12-25T14:19:52.000Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | extra[selType] must match in event urlbar#engagement#enter. - "search" matches "search" -
[task 2019-12-25T14:19:52.002Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Expected key selIndex must be in actual extra. Actual keys: [elapsed,numChars,selIndex,selType]. - true == true -
[task 2019-12-25T14:19:52.002Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | extra[selIndex] must match in event urlbar#engagement#enter. - "0" matches "0" -
[task 2019-12-25T14:19:52.003Z] 14:19:52 INFO - Running test at index 18
[task 2019-12-25T14:19:52.003Z] 14:19:52 INFO - With pageproxystate=valid, open the panel with openViewOnFocus, select with DOWN, Enter.
[task 2019-12-25T14:19:52.003Z] 14:19:52 INFO - Buffered messages logged at 14:19:14
[task 2019-12-25T14:19:52.005Z] 14:19:52 INFO - Console message: [JavaScript Error: "getScreenshot(http://example.org/) failed: TypeError: NetworkError when attempting to fetch resource." {file: "resource://activity-stream/lib/Screenshots.jsm" line: 59}]
[task 2019-12-25T14:19:52.005Z] 14:19:52 INFO - getScreenshotForURL@resource://activity-stream/lib/Screenshots.jsm:59:10
[task 2019-12-25T14:19:52.005Z] 14:19:52 INFO -
[task 2019-12-25T14:19:52.006Z] 14:19:52 INFO - Buffered messages finished
[task 2019-12-25T14:19:52.006Z] 14:19:52 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Test timed out -
[task 2019-12-25T14:19:52.006Z] 14:19:52 INFO - GECKO(2047) | MEMORY STAT | vsize 7790MB | residentFast 470MB | heapAllocated 155MB
[task 2019-12-25T14:19:52.006Z] 14:19:52 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | took 45099ms
[task 2019-12-25T14:19:52.009Z] 14:19:52 INFO - checking window state
[task 2019-12-25T14:19:52.009Z] 14:19:52 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js
[task 2019-12-25T14:19:52.357Z] 14:19:52 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-25T14:19:52.357Z] 14:19:52 INFO - Buffered messages logged at 14:19:51
[task 2019-12-25T14:19:52.357Z] 14:19:52 INFO - Entering test bound
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - Buffered messages logged at 14:19:52
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | URL bar value should match after sending a key -
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - Buffered messages finished
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js | Uncaught exception received from previously timed out test - at chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js:501 - ReferenceError: UrlbarTestUtils is not defined
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - Stack trace:
[task 2019-12-25T14:19:52.358Z] 14:19:52 INFO - tests<@chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_event_telemetry.js:501:5
[task 2019-12-25T14:19:52.539Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | Should only get a same document location change -
[task 2019-12-25T14:19:52.539Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | URL bar should not have been changed by location changes. -
[task 2019-12-25T14:19:52.543Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | URL bar value should match after sending a key -
[task 2019-12-25T14:19:52.689Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | Should only get a same document location change -
[task 2019-12-25T14:19:52.689Z] 14:19:52 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | URL bar should not have been changed by location changes. -
[task 2019-12-25T14:19:52.693Z] 14:19:52 INFO - Leaving test bound
[task 2019-12-25T14:19:52.740Z] 14:19:52 INFO - GECKO(2047) | MEMORY STAT | vsize 7783MB | residentFast 470MB | heapAllocated 157MB
[task 2019-12-25T14:19:52.742Z] 14:19:52 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_urlbar_locationchange_urlbar_edit_dos.js | took 791ms
[task 2019-12-25T14:19:52.748Z] 14:19:52 INFO - checking window state
[task 2019-12-25T14:19:52.762Z] 14:19:52 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_urlbar_remoteness_switch.js
[task 2019-12-25T14:19:53.412Z] 14:19:53 INFO - GECKO(2047) | MEMORY STAT | vsize 7788MB | residentFast 471MB | heapAllocated 165MB

[Tracking Requested - why for this release]:

I expect this is fixed by bug 1605888.

Depends on: 1605888
Flags: needinfo?(htwyford)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 73.2 - Dec 16 - Jan 5
Points: --- → 1
Flags: needinfo?(htwyford)

Harry,
Importing your patch causes Bug 1606814 to appear, can you please take a look?

Flags: needinfo?(htwyford)
Duplicate of this bug: 1606814

Alexandru, are you referring to the Phabricator patch posted in this thread? Like you applied the patch from Phabricator and that's what's causing this new failure? Or just the patch from Bug 1604932?

Flags: needinfo?(htwyford) → needinfo?(alexandru.trif)
Flags: needinfo?(alexandru.trif)

Thanks. I've updated the patch. Could it please be run again on the next beta-simulation?

Points: 1 → 2

Thank you, we'll add it in tomorrow's beta simulation.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55875e2e7f4a
Explicitly enable the openViewOnFocus pref so browser_urlbar_event_telemetry works in Beta. r=mikedeboer
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

Harry, makes sense that this patch caused this dual modality?

Flags: needinfo?(htwyford)

The change only modifies two browser-chrome test files, performance tests must be unaffected (binary and performance test framework unchanged). The dual modality disappeared later. If it affects more tests, you can ask :dhouse if there was work ongoing on the macOS machines.

Flags: needinfo?(htwyford)
You need to log in before you can comment on or make changes to this bug.