If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

enter_bug.cgi does not show description of products that start with _

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Paul Baker, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
This is similar to bug#160557. The enter_bug.cgi screen does not display the
description of products that start with _. This also affects
describecomponents.cgi as it shares the same code and template as enter_bug.cgi.

I am working on the patch for this bug and will attach it very soon.
(Reporter)

Comment 1

15 years ago
Created attachment 93632 [details] [diff] [review]
pass arrays instead of hashes to TT

This fixes the problem on my bugzilla installation.
(Reporter)

Comment 2

15 years ago
This should be all good to go if someone wants to review it.
Keywords: patch, review
And, similar to bug 160557, I'm not convinced that this is a good idea.

Updated

15 years ago
Keywords: review

Comment 4

14 years ago
> This should be all good to go if someone wants to review it.

If you want someone to review it you should request this now by setting a
review+ flag next to your attachment.
OS: Linux → All
Hardware: PC → All

Comment 5

12 years ago
Created attachment 187236 [details] [diff] [review]
patch, v1

I redefine .item() to accept keys starting with an underscore. Both products
and classifications choosers are affected.

Updated

12 years ago
Assignee: pbaker → LpSolit
Attachment #93632 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #187236 - Flags: review?(myk)
Comment on attachment 187236 [details] [diff] [review]
patch, v1

>+$Template::Stash::HASH_OPS->{ item } =
>+  sub {
>+      return $_[0]->{$_[1]};
>+  };
>+

According to a TT mailing list post from the author of TT, this is the
preferred solution to the problem right now.

http://www.template-toolkit.org/pipermail/templates/2004-January/005556.html

This solution is good for now, but ultimately we should hack TT, adding a
configuration option to turn off TT's feature for hiding hash keys, since we
don't use it, and it hurts us.


>+    [% IF proddesc.item("$p") %]
>+      <td valign="top">&nbsp;[% proddesc.item("$p") FILTER none %]</td>

These should be able to be just proddesc.item(p).

Are there any other uses of these (or other) hashes that need a similar fix?
Attachment #187236 - Flags: review?(myk) → review-

Comment 7

12 years ago
As long as TT doesn't have a param to force him to display _private keys, I don't see what I could do here...
Assignee: LpSolit → create-and-change
Status: ASSIGNED → NEW
QA Contact: mattyt-bugzilla → default-qa

Comment 8

8 years ago
I cannot reproduce this issue in Bugzilla 3.4 and newer.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.