Closed Bug 1606013 Opened 2 years ago Closed 2 years ago

Thunderbird 68.3.1 ignores userChrome.css, and ignores own preferences

Categories

(Thunderbird :: Disability Access, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: erwinm, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3

Steps to reproduce:

I opened Thunderbird.

Actual results:

It updated to 68.3.1. Now:

  1. I can't read the folder list. All the text is standard-size. I have a regular monitor and an astigmatism, so standard size is not readable.

  2. I get the gorram "to protect your privacy" messages again. So I 1st, get hit with animation as they load, and 2nd, I can't scroll normally any more.

Expected results:

It shouldn't break the folder list.

It shouldn't break the fixes to block that gorram animated non-scrolling message.

It shpouldn't break any other accessibility fixes.

I was using the following userChrome.css

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

/*The line to always hide the 'remote content' notification bar */

#msgNotificationBar {display: none !important;}

/* Global UI font */

  • { font-family: Andika !important; }
  • { font-size: 16pt !important; }

/* Message List */

#threadTree {
font-size: 16pt !important;
color: black !important
}

treechildren::-moz-tree-row {
margin-top: 0pt !important;
margin-bottom: 8pt !important;
}

/* Folder List */

#folderTree {
font-size: 16pt !important;
}

treechildren::-moz-tree-row {
margin-top: 0pt !important;
margin-bottom: 8pt !important;
}

Thunderbird 68.3.1 does not honor the userChrome.css or its own preferences. Installing Thunderbird 67.0.3 over 68.3.1 resulted in an error message and I cannot access my Thunderbird profile.

Summary: Thunderbird 68.3.1 breaks readability fixes → Thunderbird 68.3.1 ignores userChrome.css, and ignores own preferences

Note:

toolkit.legacyUserProfileCustomizations.stylesheets is currently set to "true"

It is still being ignored. It is also hard to search about:config without user css loading.

In addition, I can't find an inspector to try to diagnose the css, to fix it, so I can read text again.

Component: Untriaged → Disability Access

I tried setting toolkit.legacyUserProfileCustomizations.stylesheets to "false," quitting, restarting, and setting it to "true" again, to see if that would work. No.

Open about:config, search, it is "true." although it's being ignored.

Turn it to "false."

Quit.

Restart.

Open about:config, search, it is "true." although it's still being ignored.

Probably caused by bug 1523957 which replaced trees...

Edit: If you would use bug ###### then bugzilla will like the bug numbers for you

(In reply to MarjaE from comment #1)

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

Try removing this line.

Thank you, I also had to find new css to block the alerts.

So updating the css worked?

Yes. I don't know why the preferences didn't apply to the folder list though.

Duplicate of this bug: 1606042
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.