sjsu.edu - Rollover images don't appear

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Emanuel Ravelli, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020801
BuildID:    2002080105

Some rollover images don't load with page. Clicking on a daughter page seems to
load the images. These oages DO work in other browsers including Mozilla (God
bless you all).

Reproducible: Always
Steps to Reproduce:
1. Go to <www.pullingrank.com>.
2. Mouseover navbar at top. Images don't change.
3. Click on any navbar image. Images now change with mouseover.

Actual Results:  Some rollover images don't load with page. Clicking on a
daughter page seems to load the images.

Expected Results:  Rollover images should load with page and be displayed with
mouseover.

Comment 1

16 years ago
Browser, not engine. Reassigning to Browser-General until we can
get more information.

When I go to http://www.pullingrank.com, I see a green box to the left
containing "Why", "What", "How", etc. Is that what you mean by the navbar?
On WinNT, the behavior I'm seeing is identical in IE6 and Moz 2002-07-25.
When I mouseover an item, it turns red This is the result of image swaps

e.g. from http://www.pullingrank.com/assets/why_nav_button.gif
     to   http://www.pullingrank.com/assets/why_nav_button_over.gif


Perhaps this is Mac OSX-specific, or due to a recent regression.
Emanuel: are you getting any errors in
         
          Tools > Web Development > JavaScript Console?

(be sure to clear it of any previous errors first)
Assignee: rogerl → Matti
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → asa

Comment 2

16 years ago
Emanuel reports:

---

Forgive me, gentlemen. The URL that displays the bug is 
<http://www.sjsu.edu/depts/english/sjawp>. I was working on
another project simultaneously and gave you an incorrect URL.

--

So I'm changing the URL to http://www.sjsu.edu/depts/english/sjawp

Comment 3

16 years ago
When I load this site, I see this in the JavaScript Console:

Warning: The stylesheet http://www.sjsu.edu/depts/english/sjawp/sjawp.css
was loaded as CSS even though its MIME type, "application/x-pointplus",
is not "text/css".


Error: MM_preloadImages is not defined


Most of the rollovers seem to work for me with Mozilla on WinNT,
except for the "Home" item, which remains switched "on"...

Comment 4

16 years ago
using moz1.1b on winme.

wfm, though the mouseover images take far too long to load.  venkman throws a
fit with the mouseover script, but i'm far from a js expert.  both the js
console and venkman report "deprecated arguments usage" on the first line of the
function MM_nbGroup, as well as the undefined properties "MM_nbGroup.arguments"
and "img.MM_dn".  

because the problem appears to be intrinsic, suggest resolving as invalid.

Comment 5

16 years ago
WorksForMe using FizzillaCFM/2002080203. The "About SJAWP," "Events,"
"Registration," "Administrators," and "Contact Us" graphics change on mouseover.
What's the problem here?
(Reporter)

Comment 6

16 years ago
"venkman throws a fit with the mouseover script..." is irrelevant. The
JavaScript was produced with Dreamweaver. Since the application is ubiquitous,
the ability to manage the huge number of such scripting must be dealt with.
Access the Web pages with Mozilla or any other browser, and the rollovers
function quickly. Can Chimera afford not to?

I've been downloading the nightly builds since v.3. Today (8/2/02) I retried
<http://www.sjsu.edu/depts/english/sjawp>, and the rollovers worked for the
first time with Chimera--but slowly. Why? I don't know. Does that makes the
problem intermittant?
(Reporter)

Comment 7

16 years ago
I apologize. I had Mozilla open. Downloaded the latest build. The problem is
unresolved and reproducible.

Comment 8

16 years ago
Sounds like this bug should either go to Networking: Cache
or ImageLib. I don't know which -

Emanuel: do you have any settings in Edit > Preferences that 
might affect the behavior you're seeing? 

Also: how fast is your Internet connection? Perhaps that is
playing a role as well...
(Reporter)

Comment 9

16 years ago
Phil, all preferences (well, there aren't many) are set correctly for JavaScript
to function. (Incidentally, preferences are located as follows in Mac OS X:
Navigator > Preferences.)

I have a solid ADSL connection.

Comment 10

16 years ago
Also WorksForMe using Chimera/20020801.

The difference between the front page and the other pages is that the other
pages contain an image preloading script; the front page doesn't. (Look for
"function MM_preloadImages()".) That's why they take longer to appear there,
Emanuel; the rollover images aren't even requested by Mozilla until you actually
do mouseover them.

Thus, Mozilla is behaving properly. It can't preload images when it's not asked
to. The images will appear if you put the mouse cursor over the image and leave
it there.

That said, unless someone has a better explanation, this bug should be resolved
Invalid.
(Reporter)

Comment 11

16 years ago
Another thing before we leave this issue: Why were the rollovers working in
Mozilla, MSIE (Windows 2000 and Mac), Netscape (any flavor, Windows 2000 and
Mac), and OmniWeb and not Chimera? Your answer makes sense, so this is NOT a
criticism, just a curiosity.

Comment 12

16 years ago
I don't know why they weren't working in Chimera. Are they still not working in
Chimera? They do for me (see comment 10).

They should always work; just more slowly than on their other pages.
(Reporter)

Comment 13

16 years ago
Wrote "preload images" instructions into the JavaScript. The rollover images
still do not perform correctly. Rollovers don't work at all when the homepage is
first loaded. But reload the page and--voila!

This procedure is unnecessary in any other browser. I agree with Comment #10,
"They should always work; just more slowly than on their other pages."

Comment 14

16 years ago
Emanuel, please attach your revised page to this bug (or let us know what URL it
may be viewed at).
(Reporter)

Comment 15

16 years ago
The URL is <http://www.sjsu.edu/depts/english/sjawp/>. Very sorry.

Comment 16

16 years ago
Related to bug 93461 ?
"Images swapped via JS are loaded again and again from network"
(Reporter)

Comment 17

16 years ago
Are you saying that the rollovers are working for you? If so, they aren't for
me--ever. Are you using the Mac OS X platform?

Comment 18

16 years ago
On WinNT, all the rollovers work for me with trunk 20020805xx,
except the first one, "Home", which remains permanently green.

I guess this is not related to bug 93461 as I suggested,
because the rollovers are working fine for you on Reload -

Comment 19

16 years ago
Emanuel, the rollovers at that URL still WorkForMe using FizzillaCFM/2002080508,
on the initial load.
(Reporter)

Comment 20

16 years ago
Regarding comment #19: Greg, just tried
<http://www.sjsu.edu/depts/english/sjawp/> using build 2002808605. Rollovers
don't work unless I hit reload. Just to be certain, I emptied the cache beforehand.

Incidentally, Phil (#18) has it right; the Home graphic remains green.
(Reporter)

Comment 21

16 years ago
Gentlemen, I need your advice. There is still no performance change in build
2002081205. Rollovers do not initially function when
<http://www.sjsu.edu/depts/english/sjawp/> is first loaded; okay after clicking
Reload. This page works first time, every time with every other browser and
platform.

The question: how do you want me to deal with this? Stop bugging (no pun
intended) you? Keep downloading the daily builds? I'm here to help.

E. Ravelli

Comment 22

16 years ago
Emanuel: what about my question in Comment #1 above?

> Are you getting any errors in
>          
>    Tools > Web Development > JavaScript Console?

> (be sure to clear it of any previous errors first)



Note: here is a javscript:URL you can try:

javascript: var img = MM_findObj("About"); void(img.src =
"assets/navigation/AboutGn.gif");

(this should all fit on one line in the URL bar)


STEPS TO FOLLOW:
1. Clear the cache and load the site for the first time
2. Don't mouseover any of the buttons!!!
3. Note the "About SJAWP" button is grey
4. Enter that javascript:URL and hit <Enter>
5. Does the "About SJAWP" button change to green?
6. You can toggle back to gray by changing the javascript:URL at the end.
   Instead of "AboutGn.gif" it would be "AboutGy.gif"



Does all this work on the very first load of the site?
That's how the site is changing the .gif's dynamically.



If you have ever used a debugger and want to explore this in complete
detail, try Mozilla's JavaScript Debugger, "Venkman":

      Tools > Web Development > JavaScript Debugger

See the projects page at 

      http://www.mozilla.org/projects/venkman/

particularly the links in the "Further Reading" section at the bottom,
e.g."Venkman 0.9.x Frequently Asked Questions"

In the "Loaded Scripts" pane  in Venkman, before doing anything,
right-click on the function MM_initTimelines() and select 

                 File Options > Don't Debug

because that particular function calls itself recursively and will waste
all your debugging cycles.  The line that changes the images to green for me
is line 31:


function MM_nbGroup(event=string:"over", grpName=string:"About")
{
                    etc.
                    etc.

  img.src = (img.MM_dn && args[i + 2]) ? args[i + 2] : args[i + 1];  

                    etc.
                    etc.
}


A typical value of |args[i+1]| is:

           "assets/navigation/AboutGn.gif"

which is the "green" version of the "About SJAWP" button


If anyone on this bug would like to debug this, please do.
I can't make headway because I'm not seeing the bug -

Comment 23

16 years ago
Typo in Comment #22:

                     File Options     > Don't Debug
        should be:   Function Options > Don't Debug


We only want to avoid debugging that one function! And the
function to avoid is MM_timelinePlay(), not MM_initTimelines()
as I typed above. 

Alternatively, clicking on the file in the Loaded Scripts
pane of Venkman and selecting this might work, as well:

      File Options   > Don't Debug Eval/Timeouts 

The goal is to avoid the setTimeouts() that the function
MM_timelinePlay() uses to call itself recursively -
(Reporter)

Comment 24

16 years ago
Phil,

> Are you getting any errors in
>          >    Tools > Web Development > JavaScript Console?

The answer is "yes." 

Error: syntax error
Source File: javascript: http://www.sjsu.edu/depts/english/sjawp/
Line: 1, Column: 40
Source Code:
 http://www.sjsu.edu/depts/english/sjawp/

I'm not JavaScript savvy, however, I tried your suggestion of putting
<javascript: var img = MM_findObj("About"); void(img.src
"assets/navigation/AboutGn.gif");> in the address field. The "About" button
didn't turn green, but Voila, the rollovers worked immediately thereafter. 

I'll have to investigate your other suggestions (thank you). But still there's
that nagging question: Why only in Navigator? All other browsers function
perfectly. I have a headache!

Comment 25

16 years ago
Emanuel: thanks. Don't worry about Venkman if it is completely
new to you: the code at this site is not easy to decipher!


What happens if you try a new Mozilla profile? If the Profile Manager
doesn't come up automatically when Mozilla starts, you should be able
to force it by launching Mozilla from a console window like this:

        [(path to mozilla)]./mozilla -profilemanager

Once this comes up, click "Create New Profile" and run Mozilla
under that. Does the bug go away? 


Another question: what setting do you have in Mozilla under

                 View > Character Coding ?


Finally: try the reduced testcase I will attach below. 
Does the bug still occur? Thanks -

Comment 26

16 years ago
Created attachment 95054 [details]
Reduced testcase #1

Comment 27

16 years ago
Note: if you get a chance, try testcase #1 both by clicking on it
as an attachment here, and also by saving it as a local file and
running it locally. Does the bug go away when run locally?

Comment 28

16 years ago
I tried to reproduce the bug on Mac OS X (version 10.1.5) with Mozilla 
(Build:2002081308) and was not able to reproduce the bug.
==> default owner
Assignee: matti → asa

Updated

16 years ago
Summary: Rollover images don't appear → sjsu.edu - Rollover images don't appear

Comment 30

16 years ago
Emanuel, can you still reproduce this problem using a current nightly build?
(Reporter)

Comment 31

16 years ago
As of February 13, 2003, using Build ID: 2003021207, I no longer see this
problem. Thank you for following up.

Comment 32

16 years ago
Resolving WFM per comment 31.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.