Closed Bug 1606193 Opened 1 year ago Closed 11 months ago

Run `mach try` with Python 3

Categories

(Firefox Build System :: Try, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1632429

People

(Reporter: xidorn, Unassigned)

References

Details

Whenever I run ./mach try chooser, it shows the following warning:

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support

It seems something should be migrated to Python 3?

I'm on Ubuntu 19.10, FWIW.

Depends on: mach-py3

(In reply to Xidorn Quan [:xidorn] UTC+11 from comment #0)

Whenever I run ./mach try chooser, it shows the following warning:

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support

It seems something should be migrated to Python 3?

I'm on Ubuntu 19.10, FWIW.

The work to migrate mach commands to python3 is ongoing, but there are a lot of dependencies that need tackling. I haven't looked into mach try chooser but hopefully it isn't too much work.

Looks like to convert mach try to run on python3 would require some dependencies like mozbuild to be converted to python3 first, which is progressing at a moderate pace.

Until then, this cannot be worked on, and a quick search to see if there's an easy way to suppress this message turned up no useful results for me, so I will mark this as a bug for later.

Blocks: mach-py3
Depends on: 1611358
No longer depends on: mach-py3
Priority: -- → P3
Summary: mach try chooser shows Python deprecation warning → Run `mach try` with Python 3
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1632429
You need to log in before you can comment on or make changes to this bug.