Closed Bug 16065 Opened 20 years ago Closed 20 years ago

Keyboard navigation not jumping to proper UI elements

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P2)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: fornixon, Assigned: mcafee)

References

()

Details

The tab position is not being updated when a user clicks on an element of a
page. For example, on the bug entry form, clicking the url text box and
pressing tab should bring the cursor to the summary box, but instead starts
going through each element from the start of the page.
Assignee: shuang → don
Component: UE/UI → XPApps
Summary: tab switching between elements → Keyboard navigation not jumping to proper UI elements
Assignee: don → mcafee
Severity: minor → normal
Priority: P3 → P2
Target Milestone: M15
Chris, find out if this is our bug to fix or something for the layout/widget
guys.
fornixon@globalserve.net is now the-enigman@home.com. CC'ing the new address to
ensure I am notified of all changes to this bug.
This appears to have been fixed some time ago, prior to 1999-12-22, based
on the comment by pollmann@netscape.com on that date in bug 16271, "Tab order
starts from "top" not "this" element".

In any case, I cannot reproduce this now, using the following steps:
1. Load the second page generated by http://bugzilla.mozilla.org/enter_bug.cgi
2. Type something into the "URL" field
3. Press the [TAB] key
4. Type something in the "Summary" field.

Also tested on this show_bug.cgi page, could not get tabbing navigation to
jump to the top unbidden.

Tested with: 2000-01-12-10-M13 nightly binary on Windows NT 4.0sp3
*** Bug 23283 has been marked as a duplicate of this bug. ***
QA Contact: claudius → sairuh
the-enigman@home.com, the Platform/OS on this bug report are coming up as
Other/Other; what are you running Mozilla on? This wouldn't be the first time
a bug showed up on one platform or OS only. Thanks.
OS: other → Windows 98
Hardware: Other → PC
Move to M16 for now ...
Target Milestone: M15 → M16
Target Milestone: M16 → M18
Move to M21 target milestone.
Target Milestone: M18 → M21
this looks like it's working for me on WinNT & Linux,
marking so.  Please file more-specific bugs if there's
some other things wrong, e.g. text areas seem to suck up
the tab navigation.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Component: XP Apps → Keyboard Navigation
also wfm on linux, winnt and mac.
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.