If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

background-position on UL with floated LI is not working

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Thor Larholm, Assigned: Marc Attinasi)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
 
(Reporter)

Comment 1

15 years ago
background-position on UL with floated LI is not working

test-case in URL
Everything is working fine.  Try putting a border on the <ul> to see what's
happening (there are no in-flow children, so height becomes very small, but the
background is correctly placed at the bottom left of that).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

15 years ago
QA Contact: petersen → amar
(Reporter)

Comment 3

15 years ago
Re-opening, quirks mode should consider that the floating children extend the 
height

http://jscript.dk/2002/8/moz/floatbg.htm
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
No.  Quirks mode should not consider that, because floats in fact do not expand
the height.

Quirks mode is about being compatible with common authoring practices that
happen to work in NS4 and IE.  This is not such a practice, by any means...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
 Verified Invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.