[RFE] store bookmarks in IE fashion (multiple files on native filesystem directory tree, one bookmark per file)

RESOLVED DUPLICATE of bug 157729

Status

--
enhancement
RESOLVED DUPLICATE of bug 157729
16 years ago
14 years ago

People

(Reporter: mozilla, Assigned: ben_seamonkey)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I'd love to be able to store individual bookmarks as files within a folder,
similar to how IE stores them.  The big win of this method is that it makes it
trivial to use Unison or some similar bidirectional synchronizer to maintain
separate browsers with synchronized bookmark lists.  There are other advantages,
but that's the one I desperately want.
Whiteboard: DUPEME

Comment 1

16 years ago
This is almost a dup of bug 94465.
But maybe Peter Berger has some other idea about the behaviour, so I won't
directly mark it as a dup.
Peter, if you agree that bug 94465 covers your request, please resolve this bug
as a duplicate. If not, please explain the differences.
(Reporter)

Comment 2

16 years ago
Alfonso,

I don't think this is actually a duplicate.  Bug 94465 is talking about being 
able to convert back and forth between a "bookmark.html" style bookmark 
system -- a single file with a bunch of URLs -- and a true hierarchical folder 
based system which stores separate bookmarks as .url files (eg, "this part of 
the filesystem contains my bookmarks").  This would get me 70% of the way to 
what I need, but it would involve exporting / converting the bookmarks file 
before synchronizing, and importing after synchronizing at the start of a new 
session.  I'm actually proposing that a hierarchical folder system be 
available as a native bookmark storage format, presumably as a selectable 
option.  

I'm aware that the bookmark module is kinda in limbo right now, so I 
understand if this is an ambitious request.  But reaching is good.

[An alternative to this feature request would be "hey, make Mozilla support 
the use of ACAP for bookmarks, but I bet that's even a more ambitious request, 
and already requested -- see bug 31766]

Updated

16 years ago
Summary: [feature request] option to store bookmarks as separate files in folder → [RFE] store bookmarks in IE fashion (multiple files on native filesystem directory tree, one bookmark per file)

Comment 3

16 years ago
Was unable to find a dupe

==> NEW

Though I beleive this will become WONTFIX... There are many other possibilities
to automate import/export/etc.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

16 years ago
If you can explain to me how to have 3 bookmark.html files on 3 different 
machines (say, a home machine, a work machine, and a desktop) that I can keep 
in sync with a minimum of work (ie, manually diffing them by hand ever time I 
change workstations isn't reasonable), then I'll agree this doesn't need to be 
fixed.

Secretly, though, I think the better solution is ACAP, discussed in bug 
31766.  But that bug has been in the NEW state for about a year.
(Reporter)

Comment 5

16 years ago
I think arguably this is really a duplicate of bug 124029.  No objection to it
being closed as a dup.

Comment 6

16 years ago
Not that I propose this as an ultimate solution, but I beleive this nifty tool
is worth looking:

http://www.softgauge.com/compass/

Comment 7

16 years ago
I'd like to second (or third or 45236th) this request.

I could not possibly care less about import and export of bookmarks - what I
*do* care about is being able to effortlessly keep bookmarks synchronized on
multiple computers, being able to make updates on any computer then go to
another computer and use them.

In windows, bookmarks should be stored in the profile so it can roam (and they
already are, great), but that's not enough.  I can easily rsync between all of
the machines I use if I can keep my bookmarks in seperate files.

I'd even be satisfied with just being able to have more than one bookmark file
show up in the bookmarks menu without any fancy merging - just show each file as
a separate folder.  That would get the job done and ought to be easy enough to
implement.  ...ok, so when I say "easy" I'm doing it from my easy chair and
talking about pseudocode. :-)  But this would be *the* feature that I could use
to get people to stop using IE in favor of Mozilla.
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey

Comment 9

15 years ago
(In reply to comment #0)
> I'd love to be able to store individual bookmarks as files within a folder,
> similar to how IE stores them.

The reason, why I don't use IE bookmarks is, that IE stores bookmarks as
separate files. Just imagine, if you have 20.000 bookmarks. You also lose a lot
space, and makes the bookmarks management difficulter, not to mention about the
bookmarks which use special characters in the title. Uh, brrrrrr.... 

If Mozilla would store bookmarks in separate files, I would stop using it.
Product: Browser → Seamonkey

Comment 10

14 years ago
Also similar to Bug 124029 'Roaming - 4.x-HTTP-compatible' since the reporter
actually wanted to sync his bookmarks.

*** This bug has been marked as a duplicate of 157729 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.