Closed Bug 1606814 Opened 9 months ago Closed 9 months ago

Perma Beta TEST-UNEXPECTED-FAIL |browser_urlbar_top_sites.js | The number of results should be the same as the number of Top Sites (6). - 1 == 6 - JS frame :: <...>browser_urlbar_top_sites.js :: topSitesShown when Gecko 73 merges to Beta on 2020-01-06

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1605940

People

(Reporter: malexandru, Unassigned)

Details

Central as Beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=283326742&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=a8c659ef30c21235cb849dfd48366cac69c23024&searchStr=%28bc

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=283326742&repo=try&lineNumber=3238

[task 2020-01-03T11:46:37.027Z] 11:46:37 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js
[task 2020-01-03T11:46:37.562Z] 11:46:37 INFO - TEST-INFO | started process screentopng
[task 2020-01-03T11:46:38.111Z] 11:46:38 INFO - TEST-INFO | screentopng: exit 0
[task 2020-01-03T11:46:38.112Z] 11:46:38 INFO - Buffered messages logged at 11:46:37
[task 2020-01-03T11:46:38.113Z] 11:46:38 INFO - Entering test bound init
[task 2020-01-03T11:46:38.113Z] 11:46:38 INFO - Leaving test bound init
[task 2020-01-03T11:46:38.114Z] 11:46:38 INFO - Entering test bound topSitesShown
[task 2020-01-03T11:46:38.114Z] 11:46:38 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The test suite browser should have 6 Top Sites. - 6 == 6 -
[task 2020-01-03T11:46:38.114Z] 11:46:38 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | UrlbarView should be open. - true == true -
[task 2020-01-03T11:46:38.114Z] 11:46:38 INFO - Buffered messages finished
[task 2020-01-03T11:46:38.115Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The number of results should be the same as the number of Top Sites (6). - 1 == 6 - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: topSitesShown :: line 49
[task 2020-01-03T11:46:38.115Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.115Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:topSitesShown:49
[task 2020-01-03T11:46:38.116Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.117Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The Top Site URL and the result URL shoud match. - "https://www.youtube.com/" == "http://example.com/" - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: topSitesShown :: line 67
[task 2020-01-03T11:46:38.117Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.118Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:topSitesShown:67
[task 2020-01-03T11:46:38.118Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.119Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The Top Site title and the result title shoud match. - "youtube" == "mochitest index /" - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: topSitesShown :: line 72
[task 2020-01-03T11:46:38.120Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.120Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:topSitesShown:72
[task 2020-01-03T11:46:38.121Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.124Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | Uncaught exception - at resource://testing-common/UrlbarTestUtils.jsm:130 - TypeError: element is undefined
[task 2020-01-03T11:46:38.124Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.124Z] 11:46:38 INFO - getDetailsOfResultAt@resource://testing-common/UrlbarTestUtils.jsm:130:18
[task 2020-01-03T11:46:38.125Z] 11:46:38 INFO - Leaving test bound topSitesShown
[task 2020-01-03T11:46:38.125Z] 11:46:38 INFO - Entering test bound selectSearchTopSite
[task 2020-01-03T11:46:38.126Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.126Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | First result should have SEARCH type. - 3 == 2 - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: selectSearchTopSite :: line 98
[task 2020-01-03T11:46:38.126Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.127Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:selectSearchTopSite:98
[task 2020-01-03T11:46:38.127Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.127Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | First result should have the Amazon keyword. - "undefined" == "@amazon" - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: selectSearchTopSite :: line 104
[task 2020-01-03T11:46:38.128Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.128Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:selectSearchTopSite:104
[task 2020-01-03T11:46:38.128Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.129Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The Urlbar should be populated with the search alias. - "example.com" == "@amazon " - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: selectSearchTopSite :: line 112
[task 2020-01-03T11:46:38.129Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.129Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:selectSearchTopSite:112
[task 2020-01-03T11:46:38.129Z] 11:46:38 INFO - Leaving test bound selectSearchTopSite
[task 2020-01-03T11:46:38.130Z] 11:46:38 INFO - Entering test bound topSitesBookmarksAndTabs
[task 2020-01-03T11:46:38.456Z] 11:46:38 INFO - Console message: [JavaScript Error: "getScreenshot(http://example.com/) failed: TypeError: NetworkError when attempting to fetch resource." {file: "resource://activity-stream/lib/Screenshots.jsm" line: 59}]
[task 2020-01-03T11:46:38.456Z] 11:46:38 INFO - getScreenshotForURL@resource://activity-stream/lib/Screenshots.jsm:59:10
[task 2020-01-03T11:46:38.456Z] 11:46:38 INFO -
[task 2020-01-03T11:46:38.547Z] 11:46:38 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The test suite browser should have 7 Top Sites. - 7 == 7 -
[task 2020-01-03T11:46:38.589Z] 11:46:38 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | UrlbarView should be open. - true == true -
[task 2020-01-03T11:46:38.590Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.590Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The number of results should be the same as the number of Top Sites (7). - 1 == 7 - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: topSitesBookmarksAndTabs :: line 157
[task 2020-01-03T11:46:38.590Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.590Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:topSitesBookmarksAndTabs:157
[task 2020-01-03T11:46:38.593Z] 11:46:38 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The example.com Top Site should be the second result. - "http://example.com/" == "http://example.com/" -
[task 2020-01-03T11:46:38.594Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.595Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | The example.com Top Site should appear in the view as an open tab result. - 2 == 4 - JS frame :: chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js :: topSitesBookmarksAndTabs :: line 169
[task 2020-01-03T11:46:38.595Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.596Z] 11:46:38 INFO - chrome://mochitests/content/browser/browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js:topSitesBookmarksAndTabs:169
[task 2020-01-03T11:46:38.598Z] 11:46:38 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-03T11:46:38.598Z] 11:46:38 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | Uncaught exception - at resource://testing-common/UrlbarTestUtils.jsm:130 - TypeError: element is undefined
[task 2020-01-03T11:46:38.599Z] 11:46:38 INFO - Stack trace:
[task 2020-01-03T11:46:38.599Z] 11:46:38 INFO - getDetailsOfResultAt@resource://testing-common/UrlbarTestUtils.jsm:130:18
[task 2020-01-03T11:46:38.599Z] 11:46:38 INFO - Leaving test bound topSitesBookmarksAndTabs
[task 2020-01-03T11:46:38.739Z] 11:46:38 INFO - GECKO(2986) | MEMORY STAT | vsize 20975702MB | residentFast 1791MB
[task 2020-01-03T11:46:38.740Z] 11:46:38 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_urlbar_top_sites.js | took 1714ms

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1605940
You need to log in before you can comment on or make changes to this bug.