Closed Bug 16069 Opened 20 years ago Closed 20 years ago

parser comment handling regression

Categories

(Core :: HTML: Parser, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: kipp, Assigned: harishd)

Details

Attachments

(4 files)

See the attached test case. For some reason the parser ends the comment when it
sees the <a href=... tag.
Attached file a test case
Assignee: rickg → harishd
Harish -- since you've been changing comment handling, this one is for you.
I guess the behavior ( in noquirks )is right!!

W3C --

A common error is to include a string of hyphens ("---") within a comment.
Authors should avoid putting two or more
adjacent hyphens inside comments
Attached file No quirks
Attached file Quirks
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Since the behavior is right I'm marking the bug INVALID.
Status: RESOLVED → VERIFIED
verified
You need to log in before you can comment on or make changes to this bug.